summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-30 20:28:25 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-30 20:58:03 +0200
commit3c5de23dea9b039e0202ed46a86eb4ead0f5c7f6 (patch)
tree1cedbd2035bac245148349c1cd624e9ba7c309cf
parentkde-apps/kget: Restrict tests in this version (diff)
downloadgentoo-3c5de23d.tar.gz
gentoo-3c5de23d.tar.bz2
gentoo-3c5de23d.zip
net-irc/znc-igloo-push: new package
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--net-irc/znc-igloo-push/Manifest1
-rw-r--r--net-irc/znc-igloo-push/metadata.xml15
-rw-r--r--net-irc/znc-igloo-push/znc-igloo-push-20200520.ebuild37
3 files changed, 53 insertions, 0 deletions
diff --git a/net-irc/znc-igloo-push/Manifest b/net-irc/znc-igloo-push/Manifest
new file mode 100644
index 000000000000..9637995ec7b8
--- /dev/null
+++ b/net-irc/znc-igloo-push/Manifest
@@ -0,0 +1 @@
+DIST znc-igloo-push-20200520.tar.gz 12071 BLAKE2B 41272e479b8a6e201e3981e04f88a216aee9ed7051ae5573ea5266d74219a0a3f441ccf5621e040d4feb4bb81c349dfdc73357d7d43cf3f358a181a52bf79be7 SHA512 aaf23e1ffec4c0b5e14d9abc7ce276cc27f342e24f32fdd54f451d53729ce24fbf3665f2ad266bf38bbea2485386045c1cbc46593ed2eb6b87ac8889b8b7772e
diff --git a/net-irc/znc-igloo-push/metadata.xml b/net-irc/znc-igloo-push/metadata.xml
new file mode 100644
index 000000000000..65e385ef1366
--- /dev/null
+++ b/net-irc/znc-igloo-push/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <longdescription>
+ A ZNC module which provides push notifications through ZNC
+ for the iOS Igloo App while being disconnected from IRC.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://git.jordanko.ch/Igloo/Push/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/net-irc/znc-igloo-push/znc-igloo-push-20200520.ebuild b/net-irc/znc-igloo-push/znc-igloo-push-20200520.ebuild
new file mode 100644
index 000000000000..4022d504d1af
--- /dev/null
+++ b/net-irc/znc-igloo-push/znc-igloo-push-20200520.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_COMMIT="f952b87a1fc235917a28fbabbe8626719d622e4c"
+
+DESCRIPTION="A ZNC module which provides push notifications for Igloo client"
+HOMEPAGE="https://git.jordanko.ch/Igloo/Push"
+SRC_URI="https://git.jordanko.ch/Igloo/Push/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-irc/znc:=[ssl]"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md )
+
+S="${WORKDIR}/push"
+
+src_prepare() {
+ default
+
+ # No parallel build support
+ MAKEOPTS=-j1
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/znc
+ doins push.so
+
+ einstalldocs
+}