summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-30 15:28:05 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-30 16:24:28 +0200
commit3c6d86b32c7285e54d4ec0bd68bf5fb162eca549 (patch)
treebb2cd836c9f1425110b886088685012db8b85910
parentdev-ml/ocaml-ssl: drop old 0.5.12 (diff)
downloadgentoo-3c6d86b32c7285e54d4ec0bd68bf5fb162eca549.tar.gz
gentoo-3c6d86b32c7285e54d4ec0bd68bf5fb162eca549.tar.bz2
gentoo-3c6d86b32c7285e54d4ec0bd68bf5fb162eca549.zip
dev-ml/ocaml-ssl: bump to 0.7.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-ml/ocaml-ssl/Manifest1
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.7.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/Manifest b/dev-ml/ocaml-ssl/Manifest
index 621ae701bc98..4ee5c4065475 100644
--- a/dev-ml/ocaml-ssl/Manifest
+++ b/dev-ml/ocaml-ssl/Manifest
@@ -1 +1,2 @@
DIST ocaml-ssl-0.5.13.tar.gz 40604 BLAKE2B 289f631e360581ddfe2fa6572d1b8883853e65c438542593f5f0be5c23b1c8056c10fe6397ba8df577ebf7a9e22cbe4723d8fccabeb373de3efebee310293653 SHA512 ca1106642cb536672dba00ff4421ade2293de6f79c94a47df27520ce6f2ff4555f8e9794736afe4ce37e131a518658d0f8c57f3b106b0187216db1a461f99867
+DIST ocaml-ssl-0.7.0.tar.gz 56102 BLAKE2B b3e41eb91c3948dcd2396de0fee0b737e40a5ca076942908e6801e8ae333174ccc6068f201e69cab88989233407f3e1a690bf4635b304f89637a0460dd80d926 SHA512 969c4d64828449a49bdef26ca5f8faa72d2fe2a2304ccbf589a3ff097c2bf8ae9eb83ae1c90216f6b4d6f359e462ea47e0106a7386e26848d14910138fcb07f8
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.7.0.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.7.0.ebuild
new file mode 100644
index 000000000000..62d40f51f91d
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=ssl
+
+inherit dune
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/savonet/${PN}.git"
+else
+ SRC_URI="https://github.com/savonet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-lang/ocaml
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-ml/dune-configurator
+ test? ( dev-ml/alcotest )
+"
+
+DOCS=( CHANGES.md README.md )
+
+src_install() {
+ dune_src_install
+
+ einstalldocs
+}