summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-09 23:58:54 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-10 00:11:25 +0100
commit3c93f9d2a10e4c1725440850e77d2bc12cfce6a8 (patch)
tree29b86bedf46d7988935289bd0d4dd72191973fcd
parentsys-libs/uclibc-ng: fall back on 1.0.26 (diff)
downloadgentoo-3c93f9d2a10e4c1725440850e77d2bc12cfce6a8.tar.gz
gentoo-3c93f9d2a10e4c1725440850e77d2bc12cfce6a8.tar.bz2
gentoo-3c93f9d2a10e4c1725440850e77d2bc12cfce6a8.zip
sys-devel/clang: Raise libcxx dep for USE=default-libcxx
Require the same or newer sys-libs/libcxx version when 'default-libcxx' flag is used. This may reduce the risk of libc++ version problems on pure libc++ systems (e.g. FreeBSD) by promoting early libc++ upgrade, and it is consistent with the dependency in sys-devel/clang-runtime.
-rw-r--r--sys-devel/clang/clang-4.0.1.ebuild2
-rw-r--r--sys-devel/clang/clang-5.0.1.ebuild2
-rw-r--r--sys-devel/clang/clang-6.0.0.ebuild2
-rw-r--r--sys-devel/clang/clang-6.0.9999.ebuild2
-rw-r--r--sys-devel/clang/clang-9999.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/clang/clang-4.0.1.ebuild b/sys-devel/clang/clang-4.0.1.ebuild
index f600ff571c21..6c37d1fd9594 100644
--- a/sys-devel/clang/clang-4.0.1.ebuild
+++ b/sys-devel/clang/clang-4.0.1.ebuild
@@ -47,7 +47,7 @@ RDEPEND="${RDEPEND}
PDEPEND="
~sys-devel/clang-runtime-${PV}
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
- default-libcxx? ( sys-libs/libcxx )"
+ default-libcxx? ( >=sys-libs/libcxx-${PV} )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
diff --git a/sys-devel/clang/clang-5.0.1.ebuild b/sys-devel/clang/clang-5.0.1.ebuild
index f215ab8b2002..4c30e033af76 100644
--- a/sys-devel/clang/clang-5.0.1.ebuild
+++ b/sys-devel/clang/clang-5.0.1.ebuild
@@ -54,7 +54,7 @@ RDEPEND="${RDEPEND}
PDEPEND="
~sys-devel/clang-runtime-${PV}
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
- default-libcxx? ( sys-libs/libcxx )"
+ default-libcxx? ( >=sys-libs/libcxx-${PV} )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
diff --git a/sys-devel/clang/clang-6.0.0.ebuild b/sys-devel/clang/clang-6.0.0.ebuild
index 36d8549e27a4..e6a5cb693b98 100644
--- a/sys-devel/clang/clang-6.0.0.ebuild
+++ b/sys-devel/clang/clang-6.0.0.ebuild
@@ -56,7 +56,7 @@ RDEPEND="${RDEPEND}
PDEPEND="
~sys-devel/clang-runtime-${PV}
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
- default-libcxx? ( sys-libs/libcxx )"
+ default-libcxx? ( >=sys-libs/libcxx-${PV} )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
diff --git a/sys-devel/clang/clang-6.0.9999.ebuild b/sys-devel/clang/clang-6.0.9999.ebuild
index a9edb3ec6a20..dc7101832912 100644
--- a/sys-devel/clang/clang-6.0.9999.ebuild
+++ b/sys-devel/clang/clang-6.0.9999.ebuild
@@ -52,7 +52,7 @@ RDEPEND="${RDEPEND}
PDEPEND="
~sys-devel/clang-runtime-${PV}
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
- default-libcxx? ( sys-libs/libcxx )"
+ default-libcxx? ( >=sys-libs/libcxx-${PV} )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 015b5639dbf2..0014ecde46b2 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -53,7 +53,7 @@ RDEPEND="${RDEPEND}
PDEPEND="
~sys-devel/clang-runtime-${PV}
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
- default-libcxx? ( sys-libs/libcxx )"
+ default-libcxx? ( >=sys-libs/libcxx-${PV} )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"