summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 15:37:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 15:47:00 +0100
commit3c952cfe3ad64e62796acd682afed0b3f647b104 (patch)
treecceb186a8a16034e4a93ab8cc95d3cf527dcb9e1
parentdev-ros/rosmsg: Add missing test dep (diff)
downloadgentoo-3c952cfe3ad64e62796acd682afed0b3f647b104.tar.gz
gentoo-3c952cfe3ad64e62796acd682afed0b3f647b104.tar.bz2
gentoo-3c952cfe3ad64e62796acd682afed0b3f647b104.zip
dev-ros/test_rosmaster: install the empty message.
Bug: https://bugs.gentoo.org/624804 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/test_rosmaster/files/empty.patch12
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild2
2 files changed, 13 insertions, 1 deletions
diff --git a/dev-ros/test_rosmaster/files/empty.patch b/dev-ros/test_rosmaster/files/empty.patch
new file mode 100644
index 000000000000..8ec371c917c0
--- /dev/null
+++ b/dev-ros/test_rosmaster/files/empty.patch
@@ -0,0 +1,12 @@
+Index: test_rosmaster/CMakeLists.txt
+===================================================================
+--- test_rosmaster.orig/CMakeLists.txt
++++ test_rosmaster/CMakeLists.txt
+@@ -10,6 +10,7 @@ if(CATKIN_ENABLE_TESTING)
+ String.msg
+ Arrays.msg
+ CompositeA.msg CompositeB.msg Composite.msg
++ Empty.msg
+ Embed.msg Floats.msg Simple.msg
+ RosmsgA.msg
+ RosmsgB.msg
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild
index 2eda0a57767c..3d61a62f82a8 100644
--- a/dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild
@@ -23,7 +23,7 @@ RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
DEPEND="${RDEPEND}
test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}/yaml.patch" )
+PATCHES=( "${FILESDIR}/yaml.patch" "${FILESDIR}/empty.patch" )
mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )