summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2021-02-21 19:29:30 +0300
committerMichał Górny <mgorny@gentoo.org>2021-04-13 17:12:01 +0200
commit3cb30c619c74e081c911ac0d72cdd12bde817b75 (patch)
tree83d122db9d3d47e150f9e8205e689208f0ab7d63
parentnet-libs/glib-networking: Stabilize 2.66.0 sparc, #774927 (diff)
downloadgentoo-3cb30c619c74e081c911ac0d72cdd12bde817b75.tar.gz
gentoo-3cb30c619c74e081c911ac0d72cdd12bde817b75.tar.bz2
gentoo-3cb30c619c74e081c911ac0d72cdd12bde817b75.zip
app-arch/xarchiver: Bump to 0.5.4.17
Closes: https://bugs.gentoo.org/771951 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/19581 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-arch/xarchiver/Manifest1
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.17.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index 5712d2568a3f..b4cd271a3af5 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1 +1,2 @@
DIST xarchiver-0.5.4.15.tar.gz 1072943 BLAKE2B 6f80c8dba510bf5c05dfe5c8f12aafbd4f563861878c73b7da78562836ef4b85f9bc8e4ed7cda5d98c5e33a211a2677d163c2912f1bb605e0085627ca4ee5cbb SHA512 e5174241dd45dd6186d91b15a15b207a8b356480d9ce1a7b9ac2da167878cdb14316a3e7abf3f2aac8d41a02777df2131e205c7d5971a376ff7dd0ca70fbc82f
+DIST xarchiver-0.5.4.17.tar.gz 1077111 BLAKE2B f68f22258dbfaeb37333fab3d2ea1b06e23e143f90df6cd94f7601961636d1e5a929e1353ac956ac9a7341813593fcfb35d5197666dbb0920ddf63e4365f34e1 SHA512 5b19fd0fb90f99aee0ac2576bc4efce9ef4eef9119fc118815f6d925e3877c0895475fbdf7363d8adfb6371fb7fd73299ea3a7cb3b6d9fff19c89d1d287d3a84
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.17.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.17.ebuild
new file mode 100644
index 000000000000..019605f89c3a
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.17.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver"
+SRC_URI="https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# older pigz versions have incompatible command-line processing
+# https://bugs.gentoo.org/661464
+RDEPEND=">=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+ !!<app-arch/pigz-2.4[symlink]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}