summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlillypad <lillypadgirl86@gmail.com>2019-06-16 17:00:34 -0300
committerZac Medico <zmedico@gentoo.org>2019-06-30 14:57:06 -0700
commit3cb74f221facb32e91e2cde249f15a3fc3ce61f2 (patch)
tree5f618ec3c4ba3d2f6dbfa7ff41a83b86903e8ea1
parentsci-mathematics/msieve: Remove gwnum USE dep (diff)
downloadgentoo-3cb74f22.tar.gz
gentoo-3cb74f22.tar.bz2
gentoo-3cb74f22.zip
dev-python/billiard: Bump to version 3.6.0.0
Bug: https://bugs.gentoo.org/688034 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Lilly Chalupowski <lillypadgirl86@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--dev-python/billiard/Manifest1
-rw-r--r--dev-python/billiard/billiard-3.6.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/billiard/Manifest b/dev-python/billiard/Manifest
index 5afe878dd559..895432d8e627 100644
--- a/dev-python/billiard/Manifest
+++ b/dev-python/billiard/Manifest
@@ -1,3 +1,4 @@
DIST billiard-3.3.0.23.tar.gz 151675 BLAKE2B 78cddee80df8a7d78f993ac33b40967c1f7f7b9c65fbb27d4038b48732a90e4dc016c83e009a5963e9cc208eaa6a5f74fd4a33f3faa0f49b2112f10c285be1f1 SHA512 2ab83512f5317230066f6f82615bda97c1fe6c0cf98281dc3ed486055584c6899695e6b9905d5825d657111c65c7f3552cf3fc7934ad2e4d4b3da09b538b09ca
DIST billiard-3.5.0.0.tar.gz 155959 BLAKE2B dcfbcf7ca7d53cc1963d9753736e1001d2a4e1b19e4e67fb937619f327ec9c6af66ddf23a89ab4332499b16a6ede8bda86e82a8843a66d4d2b47d1c95885ee57 SHA512 c73adb0cd470e66cc6aaca848f24a991df3eda44e7adf0e83d2a7a1e87bba4381b165842e8cd297d43a4d01d4c006953107354b841cdad9fdde4e00e7a80c4f1
DIST billiard-3.5.0.2.tar.gz 157299 BLAKE2B 1400d5a562dcab33c83a64cc7f7d14ad55b75677c3bb4c050cd4ba08a1f882e65d033653628fc3f2b52942081da3d5661fb0bcc5f2dd95f81a64749cd47d324f SHA512 581e1ac361324b36d79e280072952e490ef3470709b094f001c579feda54578c8e7b3e5afc93a5f878a6118c56afff7e59e13b3d3f2ccb2564b9b27cc810dae7
+DIST billiard-3.6.0.0.tar.gz 151342 BLAKE2B 46e29ae54144f3b4ebf3fbb4a5bdbba29662d3a6b292cbfef526618237103fd833d10eefe03211141264424590b33ddcd8722616d36ab4e2405198628cc29d5a SHA512 0a71de026d2a781b83fe2c549ecbfe9b6fbd574d8067fc46ba7eca6b76633a123620853d22696df3563d050043cfe75b14b4b69bf5217e0af964aaa0bcbe08ff
diff --git a/dev-python/billiard/billiard-3.6.0.0.ebuild b/dev-python/billiard/billiard-3.6.0.0.ebuild
new file mode 100644
index 000000000000..087879f89dc1
--- /dev/null
+++ b/dev-python/billiard/billiard-3.6.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="https://pypi.org/project/billiard/ https://github.com/celery/billiard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="
+ >=dev-python/setuptools-20.6.7[${PYTHON_USEDEP}]
+ test? (
+ !!<dev-python/celery-4.3.0
+ >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )"
+# The usual req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}