summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-02-28 18:38:03 -0600
committerMatthias Maier <tamiko@gentoo.org>2021-02-28 18:39:42 -0600
commit3cc1d89d5b5aa267a6786f85d652187c915fae09 (patch)
treeaae8c25a19ff06d6af899d517b02ef1a0f8df18c
parentgames-board/stockfish: version bump to 13 (diff)
downloadgentoo-3cc1d89d.tar.gz
gentoo-3cc1d89d.tar.bz2
gentoo-3cc1d89d.zip
games-board/stockfish: drop broken
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--games-board/stockfish/Manifest1
-rw-r--r--games-board/stockfish/stockfish-11.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
index fd543cd52cb8..52bdaa5c7f94 100644
--- a/games-board/stockfish/Manifest
+++ b/games-board/stockfish/Manifest
@@ -1,4 +1,3 @@
DIST stockfish-10-src.zip 174377 BLAKE2B 58142b16f59f15773c8811d6e10588dbc680c94cd504d26f4ca285dbe632d845ede06571e501a4e2b77adbb9b00d91978236ff179a46a73dc9a03cfa1ae3490c SHA512 959c4f3c497ba3108884dabc38de824f11781ae57b4ab5fdf25daf9a7fc0326e663adb1c081b8c8d57a7bf5f2e941369502a50a0c93135a001c6bd1af360d0f8
-DIST stockfish-11.tar.gz 145868 BLAKE2B a4b7b523492cb37206f475cc6d7c512be2a626836e15e0cb0e98d43bf1737e569a6be5f2e87c7633c0802b44863130e7bfe47e49e99ec05015f150ff1baa9755 SHA512 3e6035d422d04a47c9fba61f3815f2be645c6c5cc8c57cc6b17f8f1f2a30651da9c51bafc19b17d4a843be1900b00c5b90e3d6fdd2c6ced45be7510feeb3559a
DIST stockfish-13-nn-62ef826d1a6d.nnue 21022697 BLAKE2B 013396fec72e14dfb90ca308bdcbaf98f27b29feb03cb2c855f521dc33d0787de51812cb2a52e4aa94622120fc89a5f2302fd6296a4fb1db33e0de57156a41c3 SHA512 25a0a1b5c440fcfaa8ee122391fbb075e4b4e6bdacae816a2897bb346c0d5c459ae464fc7680414e87eadf2a5a00565d4f3ac2c559fea4bdddd1e4a38874fba7
DIST stockfish-13.tar.gz 181226 BLAKE2B ab6f2afccce2b4767c69d07c18aa611cb71388aae9b27e8a6c95b61db4a27c18b0e7a21aa30e10b4b56d018c1a4146dcea4896c4d68d7a9f297fa0758739ce9c SHA512 5ee6581b8324ed32f02ed0f1ea5df311635203e5f1806d00f9819ad076ef4082481f8ecebbb531154cbb120bb2b396c738c3ef2e2e6ee0fd6a5bd6ff88192706
diff --git a/games-board/stockfish/stockfish-11.ebuild b/games-board/stockfish/stockfish-11.ebuild
deleted file mode 100644
index 1b453a187555..000000000000
--- a/games-board/stockfish/stockfish-11.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
-HOMEPAGE="https://stockfishchess.org/"
-
-SRC_URI="https://github.com/official-stockfish/Stockfish/archive/sf_${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
- general-32 general-64 +optimize"
-
-DEPEND="|| ( app-arch/unzip app-arch/zip )"
-RDEPEND=""
-
-S="${WORKDIR}/Stockfish-sf_${PV}/src"
-
-src_prepare() {
- default
-
- # prevent pre-stripping
- sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
- || die 'failed to disable stripping in the Makefile'
-}
-
-src_compile() {
- local my_arch
-
- # generic unoptimized first
- use general-32 && my_arch=general-32
- use general-64 && my_arch=general-64
-
- # x86
- use x86 && my_arch=x86-32-old
- use cpu_flags_x86_sse && my_arch=x86-32
-
- # amd64
- use amd64 && my_arch=x86-64
- use cpu_flags_x86_popcnt && my_arch=x86-64-modern
-
- # both bmi2 and avx2 are part of hni (haswell new instructions)
- use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
-
- # other architectures
- use cpu_flags_arm_v7 && my_arch=armv7
- use ppc && my_arch=ppc
- use ppc64 && my_arch=ppc64
-
- # Skip the "build" target and use "all" instead to avoid the config
- # sanity check (which would throw a fit about our compiler). There's
- # a nice hack in the Makefile that overrides the value of CXX with
- # COMPILER to support Travis CI and we abuse it to make sure that we
- # build with our compiler of choice.
- emake all ARCH="${my_arch}" \
- COMP=$(tc-getCXX) \
- COMPILER=$(tc-getCXX) \
- debug=$(usex debug "yes" "no") \
- optimize=$(usex optimize "yes" "no")
-}
-
-src_install() {
- dobin "${PN}"
- dodoc ../AUTHORS ../Readme.md
-}