summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-19 22:05:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-19 22:12:57 +0300
commit3cc2b2a2d98e1f90a6e2e2d661bd8706a695a7fa (patch)
treee97d0fc2ff35c5074c749e558546a37f679a5cfd
parentdev-python/phonenumbers: add 8.12.54 (diff)
downloadgentoo-3cc2b2a2.tar.gz
gentoo-3cc2b2a2.tar.bz2
gentoo-3cc2b2a2.zip
dev-python/sphinx-gallery: add 0.11.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.11.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 92a1d6e5108e..f090dc18436b 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-gallery-0.10.1.tar.gz 6546135 BLAKE2B 1f4ead74b848f28944820a77717183d845d1fba7459d11fa9bece16c5cd83742e012cce6906f8f5cd357e5c7db01107b6c7c32e2f7d5b7ce46dcd8d6a4b36e9c SHA512 da3b35907782846a58402fddf2a7f507eba76cd708725ff0ba097ec7bda6e9029252c9fb4df6d192aa7f64c6873465d4ff5e634b5c4cc6c4294e0d38c6db2f02
DIST sphinx-gallery-0.11.0.tar.gz 395136 BLAKE2B 4380484cb37baeb749469f810cbaf24f51a4f83a24a6ff868d1b8872f58db7b189575e8023926b70c576b029b895e18c3de070d69d20a87c70db5d959ebe8915 SHA512 8c97c9bea3bdeb400715bf7ad36e277c01efd5a5d9a85eaeac397eb1f7066112eaf8ef46cc42226275e50e030bfb1010d7516db70e415fbde953f051f4c3cbf4
+DIST sphinx-gallery-0.11.1.tar.gz 393927 BLAKE2B c4c56e7bc7bfc519cd172cd104cfee902524c70de7fe76cc816d8f4612cbdf1a0786e3d5f83ea74ce7c1726eeaea5db45682efa3d873efeac49d94ab1393b9ac SHA512 514139213516851fe09aac4168d8fff72e5ce62eecdb0864f58e45d5fe6eab58b8fda749b72ae98f94b2bf8ac1a917396195d8a4d1750ec1563b30b879b12b8d
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.11.1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.11.1.ebuild
new file mode 100644
index 000000000000..74dea626257b
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.11.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://sphinx-gallery.github.io/
+ https://github.com/sphinx-gallery/sphinx-gallery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=sphinx_gallery::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+)