summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-24 18:18:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-24 19:14:05 +0100
commit3ce880d3effd4e0e17a7d9a455a8da86a6fbf6f1 (patch)
treee06c979b1a51ceec9ece2c69cab76d423bd42898
parentdev-python/sphinx-autodoc-typehints: Bump to 1.21.8 (diff)
downloadgentoo-3ce880d3effd4e0e17a7d9a455a8da86a6fbf6f1.tar.gz
gentoo-3ce880d3effd4e0e17a7d9a455a8da86a6fbf6f1.tar.bz2
gentoo-3ce880d3effd4e0e17a7d9a455a8da86a6fbf6f1.zip
dev-python/nbconvert: Bump to 7.2.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbconvert/Manifest1
-rw-r--r--dev-python/nbconvert/nbconvert-7.2.9.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 285ebe10b4be..67b4297356c4 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,3 +1,4 @@
DIST nbconvert-7.1.0.tar.gz 816516 BLAKE2B c24766716212247dee90ca91a5dbcc65ae2d47b566029eb04e14e65ef94e16f6d7700ea4cc820584bc3b498553196bb5600151a30378ec82f91bf4dde68a5e77 SHA512 5d6e1c09637765e171336528219669a9279a68f3845cb0503b79129b50550f7b5a08526a30de67da6ca132ee5d911743c5afd46773598d6045f3007167f93d5b
DIST nbconvert-7.2.7.tar.gz 867872 BLAKE2B a1f209f3249b22af3153449f16c84500523dfb3efa914ae214021e5ea9174d49a3f71a860d9ccbb375f2651ee2c2a2a6834a1d2558a579dc1bd63f80172d85bc SHA512 4abf4f13a0e210a8a0338200f1dbc3e6d4d71c8565440aa08d443352e01986dada455e1b894171da1e9fa9b226ba0ea267e7fce70fca1256fc92dfe53a47de6c
DIST nbconvert-7.2.8.tar.gz 870182 BLAKE2B c6a415a93ed07ded10e318ea30918c7470df9b0ef9e7c51eceb7ee6c75c8c735ae32a459b0166d0c93ad1ec2c468ff9b0a6e4d3e86614ca1355cd8cd58423dad SHA512 e745fccf5524c46638d3c09dfafb21fb9b7e014c43ec0227f9c0e65df9892fcc06071637c17d6a2a5e5749881121a94daed29b66dd8fa27aa31568940320d22f
+DIST nbconvert-7.2.9.tar.gz 870386 BLAKE2B aea62f29d3e696c70d77ab73cc89347a4e0c8e077e98c45331608f7117fb3c98165bf3da89e4f3bf23b9d62c618289d98c9103c5b2998ca81f65cbfda65ca536 SHA512 0053e0e88f279d2fe430e516bcc19f98191e9ce414546ab1ff214f37c8f1cdfc4fc101faa4b5f1d5955fdc65c87aad367f5a5f12ce5991c68c015c5083f2f30c
diff --git a/dev-python/nbconvert/nbconvert-7.2.9.ebuild b/dev-python/nbconvert/nbconvert-7.2.9.ebuild
new file mode 100644
index 000000000000..d7f2948d80c4
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.2.9.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mistune-2.0.2[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ mkdir -p share/templates/classic/static || die
+ # tries to refetch stuff even if it's already present
+ sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
+ -i hatch_build.py || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ local src=$(
+ "${EPYTHON}" -c "import notebook as m; print(*m.__path__)" || die
+ )
+ cp "${src}/static/style/style.min.css" \
+ share/templates/classic/static/style.css || die
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Missing pyppeteer for now
+ # TODO: Doesn't skip?
+ nbconvert/exporters/tests/test_webpdf.py
+ # Needs pyppeteer too
+ 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
+ # TODO
+ nbconvert/exporters/tests/test_qtpng.py::TestQtPNGExporter::test_export
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ )
+
+ nonfatal epytest --pyargs nbconvert || die
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc ; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc."
+ fi
+}