summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGioacchino Mazzurco <gio@eigenlab.org>2018-09-01 00:48:45 +0200
committerAmy Liffey <amynka@gentoo.org>2018-09-09 16:39:58 +0100
commit3ced847e135e475663778074f797538cb6e3464a (patch)
treee95a7505ddc3a50eab060322b261cbf7d3ab2b5c
parentvirtual/rust: amd64 stable wrt bug #662904 (diff)
downloadgentoo-3ced847e.tar.gz
gentoo-3ced847e.tar.bz2
gentoo-3ced847e.zip
sci-geosciences/grass-7.4.1 version bump
Update to new version and avoid breaking addons installation by not deleting too much things in src_install Closes: https://bugs.gentoo.org/664886 Closes: https://bugs.gentoo.org/665006 Closes: https://github.com/gentoo/gentoo/pull/9748
-rw-r--r--sci-geosciences/grass/Manifest1
-rw-r--r--sci-geosciences/grass/grass-7.4.1.ebuild284
2 files changed, 285 insertions, 0 deletions
diff --git a/sci-geosciences/grass/Manifest b/sci-geosciences/grass/Manifest
index 9aaa7fc6c7a8..0f4623b3d19e 100644
--- a/sci-geosciences/grass/Manifest
+++ b/sci-geosciences/grass/Manifest
@@ -1,2 +1,3 @@
DIST grass-7.2.0.tar.gz 48315008 BLAKE2B 927da2119e199cee7cbf55a172141abfe9ce86499e307b355fec2cdf79ec3424acddc4410e3049e7cade5dd3da39e618af7e1003093f87de5735a981984b46c6 SHA512 b1aa17ec554c2f0473df3726993b0891df4589c60ca9362405932a4c479b5883245b0a0ba9e787ce2e9de210b6307f34883e4e63ddfbf04eb5d75e8583bc2c5b
DIST grass-7.4.0.tar.gz 56329374 BLAKE2B 924ecd9ad073dd3c59542a871780397a2516e1f0d912b4644978154ea6305ccf50229655aa7f38ab20f2bf85e4a4783cd793fff5101423dd6c212108d638d1df SHA512 b0393ec5d149e2146cc1f30cdcea00e31039bf0a2541486ab0ecd5debe260d267d74e60761b45ce306ad9942264cce9134dbafbf3c75a55df1c610499877d321
+DIST grass-7.4.1.tar.gz 57969640 BLAKE2B 1d3d0fd20611971ec349bf0e26ef7d886b7047e1ec48f48584f8ba2e5562f352433c9869420d7e030e66fb5a9e60de20e6a78d1fd5142380fbcab51f700766d8 SHA512 66616e495aa798cd1ad7a0284a386f7e99741918596b816a712788114e7dc491be0b5f19551f102b436518a5cabcdedbc61042acf0a9b06b9d8df12b4de26c90
diff --git a/sci-geosciences/grass/grass-7.4.1.ebuild b/sci-geosciences/grass/grass-7.4.1.ebuild
new file mode 100644
index 000000000000..5c45e10e1744
--- /dev/null
+++ b/sci-geosciences/grass/grass-7.4.1.ebuild
@@ -0,0 +1,284 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite" # bug 572440
+WANT_AUTOCONF="2.1"
+WX_GTK_VER=3.0
+
+inherit autotools gnome2 python-single-r1 versionator wxwidgets xdg-utils
+
+MY_PM=${PN}$(get_version_component_range 1-2 ${PV})
+MY_PM=${MY_PM/.}
+MY_P=${P/_rc/RC}
+
+DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
+HOMEPAGE="http://grass.osgeo.org/"
+SRC_URI="http://grass.osgeo.org/${MY_PM}/source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/7.4.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-admin/eselect-1.2
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libprojectm
+ sci-libs/proj
+ sci-libs/xdrfile
+ sci-libs/gdal
+ sys-libs/gdbm
+ sys-libs/ncurses:0=
+ sys-libs/zlib:=
+ fftw? ( sci-libs/fftw:3.0= )
+ geos? ( sci-libs/geos )
+ blas? ( virtual/blas
+ sci-libs/cblas-reference )
+ lapack? ( virtual/lapack )
+ liblas? ( sci-geosciences/liblas )
+ mysql? ( virtual/mysql )
+ netcdf? ( sci-libs/netcdf )
+ odbc? ( dev-db/unixODBC )
+ opencl? ( virtual/opencl )
+ opengl? ( virtual/opengl )
+ png? ( media-libs/libpng:0= )
+ postgres? ( >=dev-db/postgresql-8.4:= )
+ readline? ( sys-libs/readline:0= )
+ sqlite? ( dev-db/sqlite:3 )
+ tiff? ( media-libs/tiff:0= )
+ truetype? ( media-libs/freetype:2 )
+ X? (
+ dev-python/wxpython:3.0[cairo,opengl?]
+ x11-libs/cairo[X,opengl?]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ sys-devel/gettext
+ sys-devel/bison
+ X? (
+ dev-lang/swig
+ x11-base/xorg-proto
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ opengl? ( X )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-7.0.1-declare-inespg.patch
+)
+
+pkg_setup() {
+ if use lapack; then
+ local mylapack
+ mylapack=$(eselect lapack show) || die
+ if [[ -z "${mylapack/.*reference.*/}" ]] && \
+ [[ -z "${mylapack/.*atlas.*/}" ]]; then
+ ewarn "You need to set lapack to atlas or reference. Do:"
+ ewarn " eselect lapack set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ if use blas; then
+ local myblas
+ myblas=$(eselect blas show) || die
+ if [[ -z "${myblas/.*reference.*/}" ]] && \
+ [[ -z "${myblas/.*atlas.*/}" ]]; then
+ ewarn "You need to set blas to atlas or reference. Do:"
+ ewarn " eselect blas set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix unversioned python calls
+ local pyver=${EPYTHON/python/}
+ sed -e "s:GRASS_PYTHON=.*:&${pyver}:" -i "${S}/lib/init/grass.sh" || die
+ sed -e "s:= python:&${pyver}:" -i "${S}/include/Make/Platform.make.in" || die
+
+ # fix header being unconditionally included
+ # see upstream https://trac.osgeo.org/grass/ticket/2779
+ sed -e 's:\(#include <ogr_api.h>\):#ifdef HAVE_OGR\n\1\n#endif:' \
+ -i "${S}/vector/v.external/main.c" || die "failed to sed main.c"
+
+ default
+ eautoconf
+
+ ebegin "Fixing python shebangs"
+ python_fix_shebang -q "${S}"
+ eend $?
+
+ # For testsuite, see https://bugs.gentoo.org/show_bug.cgi?id=500580#c3
+ shopt -s nullglob
+ mesa_cards=$(echo -n /dev/dri/card* /dev/dri/render* | sed 's/ /:/g')
+ if test -n "${mesa_cards}"; then
+ addpredict "${mesa_cards}"
+ fi
+ ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
+ if test -n "${ati_cards}"; then
+ addpredict "${ati_cards}"
+ fi
+ shopt -u nullglob
+ addpredict /dev/nvidiactl
+
+}
+
+src_configure() {
+ if use X; then
+ WX_BUILD=yes
+ setup-wxwidgets
+ fi
+
+ addwrite "${EPREFIX}/dev/dri/renderD128"
+
+ econf \
+ --enable-shared \
+ --disable-w11 \
+ $(use_with cxx) \
+ $(use_with tiff) \
+ $(use_with png) \
+ $(use_with postgres) \
+ $(use_with mysql) \
+ $(use_with mysql mysql-includes "${EPREFIX}/usr/include/mysql") \
+ $(use_with mysql mysql-libs "${EPREFIX}/usr/$(get_libdir)/mysql") \
+ $(use_with sqlite) \
+ $(use_with opengl) \
+ $(use_with odbc) \
+ $(use_with fftw) \
+ $(use_with blas) \
+ $(use_with lapack) \
+ $(use_with X cairo) \
+ $(use_with truetype freetype) \
+ $(use_with truetype freetype-includes "${EPREFIX}/usr/include/freetype2") \
+ $(use_with nls) \
+ $(use_with readline) \
+ --without-opendwg \
+ --with-regex \
+ $(use_with threads pthread) \
+ $(use_with openmp) \
+ $(use_with opencl) \
+ --with-gdal="${EPREFIX}/usr/bin/gdal-config" \
+ $(use_with liblas liblas "${EPREFIX}/usr/bin/liblas-config") \
+ $(use_with X wxwidgets "${WX_CONFIG}") \
+ $(use_with netcdf netcdf "${EPREFIX}/usr/bin/nc-config") \
+ $(use_with geos geos "${EPREFIX}/usr/bin/geos-config") \
+ --with-proj-includes="${EPREFIX}/usr/include/libprojectM" \
+ --with-proj-libs="${EPREFIX}/usr/$(get_libdir)" \
+ --with-proj-share="${EPREFIX}/usr/share/proj/" \
+ $(use_with X x)
+}
+
+src_compile() {
+ # we don't want to link against embedded mysql lib
+ emake CC="$(tc-getCC)" MYSQLDLIB=""
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ INST_DIR="${D}/usr/$(get_libdir)/${MY_PM}" \
+ prefix="${D}/usr/" BINDIR="${D}/usr/bin" \
+ PREFIX="${D}/usr/" \
+ install
+
+ pushd "${D}/usr/$(get_libdir)/${MY_PM}" &> /dev/null || die
+
+ dodoc AUTHORS CHANGES
+ docinto html
+ dodoc -r docs/html/*
+
+ # manuals
+ dodir /usr/share/man/man1
+ rm -rf man/ || die
+
+ # translations
+ if use nls; then
+ dodir /usr/share/locale/
+ mv locale/* "${D}usr/share/locale/" || die
+ fi
+
+ popd &> /dev/null || die
+
+ # link libraries in the ~standard~ place
+ for fLib in $(ls "${D}/usr/$(get_libdir)/${MY_PM}/lib/"); do
+ dosym "${MY_PM}/lib/${fLib}" "/usr/$(get_libdir)/${fLib}"
+ done
+
+ # link headers in the ~standard~ place
+ dodir "/usr/include/"
+ dosym "../$(get_libdir)/${MY_PM}/include/grass" "/usr/include/grass"
+
+ # fix paths in addons makefile includes
+ local scriptMakeDir
+ scriptMakeDir="${D}/usr/$(get_libdir)/${MY_PM}/include/Make/"
+ for mkFile in $(ls "${scriptMakeDir}"); do
+ echo sed -i "s|${D}|/|g" "${scriptMakeDir}/${mkFile}" || die
+ sed -i "s|${D}|/|g" "${scriptMakeDir}/${mkFile}" || die
+ done
+
+ # get proper folder for grass path in script
+ local gisbase
+ gisbase="${ROOT}usr/$(get_libdir)/${MY_PM}"
+ sed -e "s:gisbase = \".*:gisbase = \"${gisbase}\":" \
+ -i "${D}usr/bin/${MY_PM}" || die
+
+ # get proper fonts path for fontcap
+ sed -i \
+ -e "s|${D}usr/${MY_PM}|${EPREFIX}usr/$(get_libdir)/${MY_PM}|" \
+ "${D}usr/$(get_libdir)/${MY_PM}/etc/fontcap" || die
+
+ # set proper python interpreter
+ sed -e "s:= \"python\":= \"${EPYTHON}\":" -i "${D}usr/bin/${MY_PM}" || die
+
+ if use X; then
+ local GUI="-gui"
+ [[ ${WX_BUILD} == yes ]] && GUI="-wxpython"
+ make_desktop_entry "/usr/bin/${MY_PM} ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
+ doicon -s 48 gui/icons/${PN}-48x48.png
+ fi
+
+ # install .pc file so other apps know where to look for grass
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins grass.pc
+
+ # fix weird +x on tcl scripts
+ find "${D}" -name "*.tcl" -exec chmod +r-x '{}' \;
+}
+
+pkg_postinst() {
+ if use X; then
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+
+ ewarn "GRASS addons may fail due to Python 3 incompatibility."
+ ewarn "If that is tha case you can change the shebang a the beginning of"
+ ewarn "the script to enforce Python 2 usage."
+ ewarn "#!/usr/bin/env python"
+ ewarn "Should be changed into"
+ ewarn "#!/usr/bin/env python2"
+}
+
+pkg_postrm() {
+ if use X; then
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}