summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-08 18:01:23 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-08 18:04:46 -0800
commit3d0b476f7886e2c28978790946bff9b58dadd1ce (patch)
treecb6598b5ca9f8b53b69a194c7fe3177641778fa0
parentdev-util/debootstrap: add 1.0.126, drop 1.0.125 (diff)
downloadgentoo-3d0b476f7886e2c28978790946bff9b58dadd1ce.tar.gz
gentoo-3d0b476f7886e2c28978790946bff9b58dadd1ce.tar.bz2
gentoo-3d0b476f7886e2c28978790946bff9b58dadd1ce.zip
www-plugins/passff-host: add 1.2.3
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--www-plugins/passff-host/Manifest2
-rw-r--r--www-plugins/passff-host/passff-host-1.2.3.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/www-plugins/passff-host/Manifest b/www-plugins/passff-host/Manifest
index a9d55db5e561..9f9f2d6f529e 100644
--- a/www-plugins/passff-host/Manifest
+++ b/www-plugins/passff-host/Manifest
@@ -1,2 +1,4 @@
DIST passff-host-1.2.2.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
DIST passff-host-1.2.2.py 3691 BLAKE2B 3fb64c6ca0d512d61f7bd3884ff5714f5a1b93095ab1c99043645d8253b5128d3d054faec6bff0f560f536b10ffa1cd523dc440b19d90cfff3bac6009f0ce86e SHA512 407be35359e987f355f04a45bf8a0c1023ee04d3c6d7c4ea9cce29955957cd514302ca04aeda4367e8560e8d765159b5fddad2e51ea089f9eb2947564605b5cf
+DIST passff-host-1.2.3.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
+DIST passff-host-1.2.3.py 3691 BLAKE2B 428573d2493f9ff8ef1dc6c8971508a05afa1bef7e06831462106e8daa98c9bedf63489e6630ff9c441ef981164656932c404ffd47e12a2e1e77a55c3ec4955e SHA512 be01e5ed3974bc0967e0dd102593ea8b4f62a5b4ca3f8f2fa2743f9abb4118334cfd27ecd595ce31dd079831614ebf8d91c5b504ad5ead067c245b921d756ceb
diff --git a/www-plugins/passff-host/passff-host-1.2.3.ebuild b/www-plugins/passff-host/passff-host-1.2.3.ebuild
new file mode 100644
index 000000000000..3c481e7e23ec
--- /dev/null
+++ b/www-plugins/passff-host/passff-host-1.2.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit python-single-r1
+
+DESCRIPTION="Host app for the PassFF WebExtension"
+HOMEPAGE="https://github.com/passff/passff-host"
+
+SRC_URI="
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.py -> ${P}.py
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.json -> ${P}.json
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="chrome chromium +firefox vivaldi"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( chrome chromium firefox vivaldi )
+"
+
+RDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.json" . || die
+ cp "${DISTDIR}/${P}.py" . || die
+}
+
+src_prepare() {
+ default
+ python_fix_shebang "${P}.py"
+}
+
+src_install() {
+ local target_dirs=()
+
+ use chrome && target_dirs+=( "/etc/opt/chrome/native-messaging-hosts" )
+ use chromium && target_dirs+=( "/etc/chromium/native-messaging-hosts" )
+ use firefox && target_dirs+=( "/usr/$(get_libdir)/mozilla/native-messaging-hosts" )
+ # www-client/firefox-bin compile-time dir is under /usr/lib/
+ use firefox && target_dirs+=( "/usr/lib/mozilla/native-messaging-hosts" )
+ use vivaldi && target_dirs+=( "/etc/vivaldi/native-messaging-hosts" )
+
+ for target_dir in "${target_dirs[@]}"; do
+ sed "s;PLACEHOLDER;${target_dir}/passff.py;g" "${P}.json" > "passff.json" || die
+
+ insinto "${target_dir}"
+ doins passff.json
+ exeinto "${target_dir}"
+ newexe "${P}.py" passff.py
+ done
+}