summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-01 15:23:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-01 17:04:08 +0100
commit3d20d83a27c70c562b2fe4286cb233ca9ee11e0d (patch)
treec055e9edaace4150d1884055aa5c6622e946a097
parentdev-python/hypothesis: Remove redundant versions (diff)
downloadgentoo-3d20d83a.tar.gz
gentoo-3d20d83a.tar.bz2
gentoo-3d20d83a.zip
dev-python/hypothesis: Bump to 4.57.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-4.57.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 98ebbd01dfdd..8d4945145525 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad258
DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b38858d47fddba613ce37eb9a9554afa3c189776e9172965dd31f8497747ac13b2ab1d34ee6de8671646972e71b82c5260db489b9a SHA512 9b6920181dca75b9e551ae5e598101f35cfc26e9e3a1b20cab652c151bc6355413d0c9602d3242fb23f808ab00335793009df938d55ee19a6af1ce2a8b085e3c
DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda97633ba420c32fda38093bb852ef45929762cade0f7f0d1ef696ff96f7ebe7460e8bf53f63de9c959bbbd9e8ec162196d307aac0 SHA512 8c77439fd029e2380afbc059d2edf977414997ba81ecdfde14dfe9dbe9515a92e701751d13879c6b879271f817e01926c2dc66945ae76eb141818da1775bc545
DIST hypothesis-python-4.55.4.tar.gz 9004357 BLAKE2B 93fe51581f044cf5f416d9b74b82ce2f9b42e7391beae8f67debdf50494e662f07bf109274d4e29fcf3a1c1c944597cde2a4ff9e7ca65a48f1244c3205f365af SHA512 91d7d2cda32fd40d5368fdd1e60b990b8307573782d822113b6817a5c0b670610693a2f2b013f828913549946fa3dc15f45303bf7d3226bdc1e4527bc18981fb
+DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
diff --git a/dev-python/hypothesis/hypothesis-4.57.1.ebuild b/dev-python/hypothesis/hypothesis-4.57.1.ebuild
new file mode 100644
index 000000000000..79eb7efd3894
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-4.57.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local pyver=$(python_is_python3 && echo 3 || echo 2)
+ pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}