summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2022-05-23 06:47:38 -0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-23 12:21:59 +0200
commit3d29fa5360c8048aea0a0df7972e974df6046318 (patch)
tree2758e695621fd54f4fe883a547551585e60c1dd4
parentgames-action/polymc: add version 1.3.0 (diff)
downloadgentoo-3d29fa5360c8048aea0a0df7972e974df6046318.tar.gz
gentoo-3d29fa5360c8048aea0a0df7972e974df6046318.tar.bz2
gentoo-3d29fa5360c8048aea0a0df7972e974df6046318.zip
games-action/polymc: drop 1.2.2
Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25604 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--games-action/polymc/Manifest2
-rw-r--r--games-action/polymc/files/polymc-iconfix.patch29
-rw-r--r--games-action/polymc/polymc-1.2.2.ebuild115
3 files changed, 1 insertions, 145 deletions
diff --git a/games-action/polymc/Manifest b/games-action/polymc/Manifest
index ad7aefc1e7e7..ac7ab8450067 100644
--- a/games-action/polymc/Manifest
+++ b/games-action/polymc/Manifest
@@ -1 +1 @@
-DIST polymc-1.2.2.tar.gz 5167667 BLAKE2B 5cc26d1650f9cf851ad01d3bc75a0ec3f19b3aa50031a91a3c9c16e9bc73dabfc495e408b8c83559026f3af03b86fdd5c83815f04c62121b71c144d1548d764c SHA512 d81d1aaba5361c8ad664bbecffd9869dda637002a5c1288142f40d21abca974d6cc03a50685be5f70a01d5b1ae8bcff4e48c5b849f6c3dcd959e5977582ada58
+DIST polymc-1.3.0.tar.gz 5115480 BLAKE2B ac818b899d25f1545ceafd109a8eb48acd6a2d4b09b8d7f5365de0fc1b6ce0171ed053bc19785192ab781a2d7f506167599e3f3747e94fe1cf62b9989208e685 SHA512 b33660dfc7026f1153aaffd4429b9047bffa9cc80a3231bb19c0f3a7d4046654c49f278d9c07ae3ac631172ed147fa06065c2713fb59221ff9131406d8c6df46
diff --git a/games-action/polymc/files/polymc-iconfix.patch b/games-action/polymc/files/polymc-iconfix.patch
deleted file mode 100644
index 01477e559ff6..000000000000
--- a/games-action/polymc/files/polymc-iconfix.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 8f494636afb9a9b9c0619b256252d3a9dcdbab72 Mon Sep 17 00:00:00 2001
-From: flow <thiagodonato300@gmail.com>
-Date: Thu, 21 Apr 2022 06:38:18 -0300
-Subject: [PATCH] fix: Build iconfix as static library
-
-Otherwise the launcher is unable to find the iconfix .so, and so the
-launcher doesn't run.
-
-Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com>
----
- libraries/iconfix/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libraries/iconfix/CMakeLists.txt b/libraries/iconfix/CMakeLists.txt
-index 08441203..97a59129 100644
---- a/libraries/iconfix/CMakeLists.txt
-+++ b/libraries/iconfix/CMakeLists.txt
-@@ -12,7 +12,7 @@ internal/qiconloader.cpp
- internal/qiconloader_p.h
- )
-
--add_library(Launcher_iconfix ${ICONFIX_SOURCES})
-+add_library(Launcher_iconfix STATIC ${ICONFIX_SOURCES})
- target_include_directories(Launcher_iconfix PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} "${CMAKE_CURRENT_BINARY_DIR}" )
-
- target_link_libraries(Launcher_iconfix Qt5::Core Qt5::Widgets)
---
-2.35.1
-
diff --git a/games-action/polymc/polymc-1.2.2.ebuild b/games-action/polymc/polymc-1.2.2.ebuild
deleted file mode 100644
index 00e26da2635e..000000000000
--- a/games-action/polymc/polymc-1.2.2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake java-pkg-2 optfeature xdg
-
-HOMEPAGE="https://polymc.org/ https://github.com/PolyMC/PolyMC"
-DESCRIPTION="A custom, open source Minecraft launcher"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="
- https://github.com/PolyMC/PolyMC
- https://github.com/PolyMC/libnbtplusplus
- "
-
- EGIT_SUBMODULES=( 'depends/libnbtplusplus' )
-else
- MY_PN="PolyMC"
-
- # Let's use the vendored tarball to avoid dealing with the submodules directly
- SRC_URI="
- https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
- "
-
- # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
- S="${WORKDIR}/${MY_PN}-${PV}"
-
- KEYWORDS="~amd64"
-fi
-
-# Apache-2.0 for MultiMC (PolyMC is forked from it)
-# GPL-3 for PolyMC
-# LGPL-3 for libnbtplusplus
-# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
-LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 OFL-1.1 MIT"
-
-SLOT="0"
-
-IUSE="debug lto"
-REQUIRED_USE="
- lto? ( !debug )
-"
-
-MIN_QT="5.6.0"
-
-QT_DEPS="
- >=dev-qt/qtconcurrent-${MIN_QT}:5
- >=dev-qt/qtcore-${MIN_QT}:5
- >=dev-qt/qtgui-${MIN_QT}:5
- >=dev-qt/qtnetwork-${MIN_QT}:5
- >=dev-qt/qttest-${MIN_QT}:5
- >=dev-qt/qtwidgets-${MIN_QT}:5
- >=dev-qt/qtxml-${MIN_QT}:5
-"
-
-# Required at both build-time and run-time
-COMMON_DEPENDS="
- ${QT_DEPS}
- >=dev-libs/quazip-1.3:=
- sys-libs/zlib
-"
-
-DEPEND="
- ${COMMON_DEPENDS}
- media-libs/libglvnd
- >=virtual/jdk-1.8.0:*
-"
-
-# At run-time we don't depend on JDK, only JRE
-# And we need more than just the GL headers
-RDEPEND="
- ${COMMON_DEPENDS}
- >=virtual/jre-1.8.0:*
- virtual/opengl
-"
-
-if [[ ${PV} != 9999 ]]; then
- PATCHES=( "${FILESDIR}/${PN}-iconfix.patch" )
-fi
-
-src_prepare() {
- cmake_src_prepare
-}
-
-src_configure(){
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX="/usr"
- # Resulting binary is named polymc
- -DLauncher_APP_BINARY_NAME="${PN}"
-
- -DENABLE_LTO=$(usex lto)
- )
-
- if use debug; then
- CMAKE_BUILD_TYPE=Debug
- else
- CMAKE_BUILD_TYPE=Release
- fi
-
- cmake_src_configure
-}
-
-src_compile(){
- cmake_src_compile
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- # https://github.com/PolyMC/PolyMC/issues/227
- optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
-}