summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-23 23:43:51 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:09:44 +0200
commit3d3a1f91e942cf0860471eb4d3d621612061a1f0 (patch)
treee5a0110c99bb096b88968b78a7874130462d6df0
parentgames-simulation/dangerdeep: Fix building with -Werror=terminate (diff)
downloadgentoo-3d3a1f91.tar.gz
gentoo-3d3a1f91.tar.bz2
gentoo-3d3a1f91.zip
games-strategy/glob2: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=610382 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5189
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-gcc6.patch49
-rw-r--r--games-strategy/glob2/glob2-0.9.4.4-r1.ebuild4
2 files changed, 51 insertions, 2 deletions
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-gcc6.patch b/games-strategy/glob2/files/glob2-0.9.4.4-gcc6.patch
new file mode 100644
index 000000000000..f1152c3ba1cc
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-gcc6.patch
@@ -0,0 +1,49 @@
+Bug: https://bugs.gentoo.org/610382
+Upstream commit: https://bitbucket.org/giszmo/glob2/commits/c9dc715624318e4fea4abb24e04f0ebdd9cd8d2a
+
+# HG changeset patch
+# User Jonathan Wakely <jwakely@redhat.com>
+# Date 1485875296 0
+# Node ID c9dc715624318e4fea4abb24e04f0ebdd9cd8d2a
+# Parent c4da01699846179d8bf21e8dae2b973158ec0775
+Fix last argument to ChooseMapScreen constructor
+
+Since C++14 'false' is not a valid null pointer constant, so cannot be passed
+to functions expecting pointer arguments.
+
+diff --git a/src/EditorMainMenu.cpp b/src/EditorMainMenu.cpp
+--- a/src/EditorMainMenu.cpp
++++ b/src/EditorMainMenu.cpp
+@@ -90,7 +90,7 @@
+ }
+ else if (par1==LOADMAP)
+ {
+- ChooseMapScreen chooseMapScreen("maps", "map", false, "games", "game", false);
++ ChooseMapScreen chooseMapScreen("maps", "map", false, "games", "game", NULL);
+ int rc=chooseMapScreen.execute(globalContainer->gfx, 40);
+ if (rc==ChooseMapScreen::OK)
+ {
+diff --git a/src/LANMenuScreen.cpp b/src/LANMenuScreen.cpp
+--- a/src/LANMenuScreen.cpp
++++ b/src/LANMenuScreen.cpp
+@@ -62,7 +62,7 @@
+ }
+ else if(par1 == HOST)
+ {
+- ChooseMapScreen cms("maps", "map", false, "games", "game", false);
++ ChooseMapScreen cms("maps", "map", false, "games", "game", NULL);
+ int rc = cms.execute(globalContainer->gfx, 40);
+ if(rc == ChooseMapScreen::OK)
+ {
+diff --git a/src/YOGClientLobbyScreen.cpp b/src/YOGClientLobbyScreen.cpp
+--- a/src/YOGClientLobbyScreen.cpp
++++ b/src/YOGClientLobbyScreen.cpp
+@@ -326,7 +326,7 @@
+
+ void YOGClientLobbyScreen::hostGame()
+ {
+- ChooseMapScreen cms("maps", "map", false, "games", "game", false);
++ ChooseMapScreen cms("maps", "map", false, "games", "game", NULL);
+ int rc = cms.execute(globalContainer->gfx, 40);
+ if(rc == ChooseMapScreen::OK)
+ {
diff --git a/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild b/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild
index a99db31f4463..3017798e40f6 100644
--- a/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild
+++ b/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -27,7 +27,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-{gcc44,scons-blows,underlinking,gcc49}.patch
+ epatch "${FILESDIR}"/${P}-{gcc{44,49,6},scons-blows,underlinking}.patch
}
src_configure() {