summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-28 13:33:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-28 13:34:44 -0500
commit3d3b9e87b8a4209fad02cf9aad0642cdd5bde75d (patch)
tree2068f8dbc8673f319812df04545dfcfe1e17ecdb
parentdev-python/python-barbicanclient: 4.5.2 bup (diff)
downloadgentoo-3d3b9e87.tar.gz
gentoo-3d3b9e87.tar.bz2
gentoo-3d3b9e87.zip
dev-python/castellan: 0.12.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/castellan/Manifest1
-rw-r--r--dev-python/castellan/castellan-0.12.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/castellan/Manifest b/dev-python/castellan/Manifest
index 33c98606a0ac..9394761fdb88 100644
--- a/dev-python/castellan/Manifest
+++ b/dev-python/castellan/Manifest
@@ -1 +1,2 @@
+DIST castellan-0.12.0.tar.gz 50497 SHA256 22194a1f2084b939652b28deca0f62312636442b0ab50511aff69a4902cf77d4 SHA512 9fe47f9678dc2528cbca652029263db89b71939e70c4f5fddffd1769271c04bec3cad0a7c29a800b646098b3df89fc064049c4fe3887695fe0b5dd6b3146835a WHIRLPOOL fe5d0e43dee622ae84210b21f68e54ef4988433a420554a925c465fcd0abedcfb2aa3f50be11085565239c56acb373800759ae3684c4bb53aac3914fa04573dc
DIST castellan-0.4.0.tar.gz 49026 SHA256 2ccefefc2036ed0d6c76d735fb70b813e2a02f7adb7fd57e0640d064dce1c883 SHA512 2ccb2a757810c6ec125dbb8832cd09f918f9fbf84836ff69c79872471c7e4e40bc8030e305336ad9821de7c3b93617d39917387a6ab8f68443fb09d3f74d4dd5 WHIRLPOOL 972ef43c96356b4dfd69a5716aa996c6b0ac4ab54a989f8e38e3036e63043a33148e0e475224cfc9c4d7e2e5f122af476553015fc840b6326f599bd472f2f936
diff --git a/dev-python/castellan/castellan-0.12.0.ebuild b/dev-python/castellan/castellan-0.12.0.ebuild
new file mode 100644
index 000000000000..2d93dd3fb60f
--- /dev/null
+++ b/dev-python/castellan/castellan-0.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.6[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}]
+"