summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-04 06:01:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-04 06:01:37 +0200
commit3d581866e0c77e060a75e866fba26615149c6164 (patch)
treeeca926b29b472d75119ecf3343a8dfbd18766801
parentdev-python/rarfile: Bump to 4.2 (diff)
downloadgentoo-3d581866e0c77e060a75e866fba26615149c6164.tar.gz
gentoo-3d581866e0c77e060a75e866fba26615149c6164.tar.bz2
gentoo-3d581866e0c77e060a75e866fba26615149c6164.zip
dev-python/pytest-jupyter: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-jupyter/Manifest1
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/Manifest b/dev-python/pytest-jupyter/Manifest
index 93b08092771e..772578259dac 100644
--- a/dev-python/pytest-jupyter/Manifest
+++ b/dev-python/pytest-jupyter/Manifest
@@ -1 +1,2 @@
+DIST pytest_jupyter-0.10.0.tar.gz 15514 BLAKE2B 668ac112374834684a3321d935d214c2eacf9bfa8d7a1e3915a882db5fa76a713acc673b3ed605326efaa39fadadb0211c529f94c9607870217ec6eafc86f08a SHA512 7d8e35ff5643703479aa116cac9b1b6d757319088b43fa3ae08a2865fc2bcf08cc25dd117edacc4695dfb2a18548d51658535984c5b0c10be14fb66e3e8cfc75
DIST pytest_jupyter-0.9.1.tar.gz 15519 BLAKE2B 58262222fec8c57bb979a66de83429dd9ed261506aa11f4737bb3e1ab2c00a81337b279b6052d4fc6996b02cfb40062d9707ec4ca5472f5a603b83a3602ecd0d SHA512 bb513b4560fb4edcebfe3bef5f62544ec241de235a23cb644a6c9830d8284b7b22ac448e48ad48350dc17fa35a9117bcceabfdbeaa578a97be3db34fa3a5a1f8
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
new file mode 100644
index 000000000000..ac7134dabd4e
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/pytest-jupyter/
+ https://pypi.org/project/pytest-jupyter/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.7[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest