summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-28 14:44:22 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-28 14:52:09 -0600
commit3d6335fda421c5152133641fe4531884555309f4 (patch)
tree4a6bcb5c22165da077550aead5502914fe998185
parentnet-misc/memcached: mark s390 stable (diff)
downloadgentoo-3d6335fd.tar.gz
gentoo-3d6335fd.tar.bz2
gentoo-3d6335fd.zip
dev-libs/msgpack: version bump to 3.1.1
Closes: https://bugs.gentoo.org/628714 Closes: https://bugs.gentoo.org/635338 Closes: https://bugs.gentoo.org/658262 Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-libs/msgpack/Manifest1
-rw-r--r--dev-libs/msgpack/metadata.xml3
-rw-r--r--dev-libs/msgpack/msgpack-3.1.1.ebuild74
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/msgpack/Manifest b/dev-libs/msgpack/Manifest
index 217c25e1585b..636a145ca555 100644
--- a/dev-libs/msgpack/Manifest
+++ b/dev-libs/msgpack/Manifest
@@ -3,3 +3,4 @@ DIST msgpack-1.4.2.tar.gz 776384 BLAKE2B c8605847aca3faa3aba2c573bc6f020fbfbc773
DIST msgpack-2.0.0-patchset.tar.bz2 1645 BLAKE2B 273faa0fe88f4da06b57b7deb02de77191bdb6c5ca76d314043636979157b879f73cbcb0a0b931cecb3eb0f706b3c6cce0e42350eebf20c44503393504c9edb0 SHA512 7b40b0e6675b333bdbf3d811e47a55e35c4aa136e378966ce3e5f42aaf6de57d883db71ed5c189c6da1803d6725847db23f6fdf1cc0cdc921d3cadcf245545c4
DIST msgpack-2.0.0.tar.gz 446063 BLAKE2B 24bb0657dc8f190740ae3f91541f702d9954e1ff6c12931c43911556a1d34634882dd59678e5aae4a4b55733620a1445c2fef0379be9454b0fa32ce5d7515f08 SHA512 74d1c9641ecdf1a54346088c59415cf778821dc6f6acb0c5a8a93c2284edaf53c4746459093971d96136279fbd8de10cb9a43dd8d8220d335618ad30e971e9a3
DIST msgpack-2.1.1.tar.gz 460168 BLAKE2B b6e3746033e4779139c5efe0d48eb00e19badff17f910f5a5cdba8ebdccb178f88cbb4e6e85687e4a2ddb0d5c9e6b53dec1e4cc2cee070b5e51e38c5a67b0ad3 SHA512 31ed6fda498d43da6fdbbe000ce36c40e4cf886f00d879c57d406def7f5bba4eaf66f02f221398cb50f6f4c748d5cde9c97eca0cfa21b368c7c933c3301cf9b5
+DIST msgpack-3.1.1.tar.gz 495858 BLAKE2B a99b7edb2a6de80e018d5c4084ea199518e34045a6293c622c8690147ae353abdb63856eb031962a02ce20903d4443ec2b01a3c033e756c339f8674ff801d4c3 SHA512 cc634ef38b3844bf994159024441fe72d99055c42b0a4d81245b0629fd1f3147587eb36537cfb85e4cae2edc1dc23d7fa400022efa5a10dca295f9a6acd38346
diff --git a/dev-libs/msgpack/metadata.xml b/dev-libs/msgpack/metadata.xml
index a58d5aff1a40..452594740686 100644
--- a/dev-libs/msgpack/metadata.xml
+++ b/dev-libs/msgpack/metadata.xml
@@ -5,6 +5,9 @@
<email>vim@gentoo.org</email>
<name>Gentoo Vim Project</name>
</maintainer>
+ <use>
+ <flag name="boost">Enable boost support</flag>
+ </use>
<upstream>
<remote-id type="github">msgpack/msgpack-c</remote-id>
</upstream>
diff --git a/dev-libs/msgpack/msgpack-3.1.1.ebuild b/dev-libs/msgpack/msgpack-3.1.1.ebuild
new file mode 100644
index 000000000000..768e32012a7b
--- /dev/null
+++ b/dev-libs/msgpack/msgpack-3.1.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
+HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
+
+LICENSE="Boost-1.0"
+SLOT="0/2"
+IUSE="boost +cxx doc examples static-libs test"
+
+RDEPEND="boost? ( dev-libs/boost[context,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ )
+ doc? ( app-doc/doxygen[dot] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMSGPACK_BOOST="$(usex boost)"
+ -DMSGPACK_ENABLE_CXX="$(usex cxx)"
+ -DMSGPACK_ENABLE_STATIC="$(usex static-libs)"
+ -DMSGPACK_BUILD_TESTS="$(usex test)"
+ # don't build the examples
+ -DMSGPACK_BUILD_EXAMPLES=OFF
+ # enable C++11 by default
+ -DMSGPACK_CXX11=ON
+ )
+ cmake-multilib_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if multilib_is_native_abi && use doc; then
+ cmake-utils_src_make doxygen
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ if use doc; then
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ mkdir docs || die
+ mv doc_c/html docs/c || die
+
+ use cxx && mv doc_cpp/html docs/cpp || die
+ fi
+
+ if use examples; then
+ docinto examples
+
+ dodoc -r "${WORKDIR}/${P}/example/."
+
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ fi
+
+ cmake-utils_src_install
+}