summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-06-26 10:15:43 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-06-26 10:17:41 -0500
commit3d75bc5deef3bd56ec28aeefdded2470b1beb434 (patch)
treef49aee6b2bb2a7bbfd26b97b5b8caf4f5a25b52a
parentsys-apps/yarn: stable 1.22.4 on amd64 (diff)
downloadgentoo-3d75bc5d.tar.gz
gentoo-3d75bc5d.tar.bz2
gentoo-3d75bc5d.zip
sys-apps/yarn: remove old
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-apps/yarn/Manifest1
-rw-r--r--sys-apps/yarn/yarn-1.22.0.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/sys-apps/yarn/Manifest b/sys-apps/yarn/Manifest
index 53cae8aaee3f..89a18c4161fb 100644
--- a/sys-apps/yarn/Manifest
+++ b/sys-apps/yarn/Manifest
@@ -1,2 +1 @@
-DIST yarn-v1.22.0.tar.gz 1244012 BLAKE2B 2764704103e281de8fd8c2c28abae56c7ba863365989b884add045d2f80810f0f8b83acd77baeef2375fe1424ad54cabfd89e4d14b38068114552115d3b7a812 SHA512 28c1cffc9ab9de364a4d8f624d4b77748565fdb7ba50fb3620da3debe0676472cac583537f03269601d368c5b2199a0eef8448e00205be75a162b5ead9448992
DIST yarn-v1.22.4.tar.gz 1244785 BLAKE2B 1f1eeb829096eaf19a8fdb48b46fa736769d9d3c247759e434413665186e4cccb750024afa836dae8a0130fc472df3c01805d263d81346e1dd7509e1b106e88a SHA512 a1833b862fe52169bd6c2a033045a07df5bc6a23595c259e675fed1b2d035ab37abe6ce309720abb6636d68f03615054b6292dc0a70da31c8697fda228b50d18
diff --git a/sys-apps/yarn/yarn-1.22.0.ebuild b/sys-apps/yarn/yarn-1.22.0.ebuild
deleted file mode 100644
index 706453936e75..000000000000
--- a/sys-apps/yarn/yarn-1.22.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="Fast, reliable, and secure node dependency management"
-HOMEPAGE="https://yarnpkg.com"
-SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="!dev-util/cmdtest
- net-libs/nodejs"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
-}
-
-src_install() {
- local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
- insinto "${install_dir}"
- doins -r .
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarnpkg" "/usr/bin/yarnpkg"
-
- while read -r -d '' path; do
- read -r shebang < "${ED}${path}" || die
- [[ "${shebang}" == \#\!* ]] || continue
- fperms +x "${path}"
- done < <(find "${ED}" -type f -printf '/%P\0' || die)
-}