summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-14 09:55:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-14 09:55:27 +0200
commit3d87a84e9efadd125720c7caf8b5045948353547 (patch)
tree4172c41f01b827fd2e05232834012f7eaebb4827
parentsci-mathematics/alt-ergo: Adding alt-ergo 1.30 (diff)
downloadgentoo-3d87a84e.tar.gz
gentoo-3d87a84e.tar.bz2
gentoo-3d87a84e.zip
media-gfx/exiv2: Fix !multilib_is_native_abi build
Gentoo-bug: 634178 Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--media-gfx/exiv2/exiv2-0.26_p20171013.ebuild2
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26_p20171013-cmake.patch47
2 files changed, 49 insertions, 0 deletions
diff --git a/media-gfx/exiv2/exiv2-0.26_p20171013.ebuild b/media-gfx/exiv2/exiv2-0.26_p20171013.ebuild
index 92035195fe46..9aa6302ffd0d 100644
--- a/media-gfx/exiv2/exiv2-0.26_p20171013.ebuild
+++ b/media-gfx/exiv2/exiv2-0.26_p20171013.ebuild
@@ -41,6 +41,8 @@ DEPEND="${RDEPEND}
DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
pkg_setup() {
use doc && python-any-r1_pkg_setup
}
diff --git a/media-gfx/exiv2/files/exiv2-0.26_p20171013-cmake.patch b/media-gfx/exiv2/files/exiv2-0.26_p20171013-cmake.patch
new file mode 100644
index 000000000000..c10f125415b2
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26_p20171013-cmake.patch
@@ -0,0 +1,47 @@
+From 57883ee664260f5a1b382575e7477ad34c86ce7d Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Fri, 13 Oct 2017 18:54:11 +0200
+Subject: [PATCH] Fix build with EXIV2_BUILD_EXIV2_COMMAND=OFF
+
+---
+ src/CMakeLists.txt | 17 ++++++++++++-----
+ 1 file changed, 12 insertions(+), 5 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index fe49a0a6..f75cbf1b 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -291,21 +291,28 @@ if(EXIV2_BUILD_EXIV2_COMMAND)
+ if ( BUILD_SHARED_LIBS )
+ target_compile_definitions(exiv2 PRIVATE EXV_HAVE_DLL )
+ endif()
++ # modify source lists to suit environment
++
++ # TODO This should not be needed here! we need to fix the previous TODO
++ target_include_directories(exiv2 PRIVATE ${CMAKE_SOURCE_DIR}/include/)
++
++ if(NOT EXV_HAVE_TIMEGM )
++ target_sources(exiv2 PRIVATE localtime.c)
++ endif()
++
++ if (MSVC)
++ target_sources(exiv2 PRIVATE getopt_win32.c)
++ endif()
+ install(TARGETS exiv2 RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+
+-# TODO This should not be needed here! we need to fix the previous TODO
+-target_include_directories(exiv2 PRIVATE ${CMAKE_SOURCE_DIR}/include/)
+-
+ # modify source lists to suit environment
+ if(NOT EXV_HAVE_TIMEGM )
+ target_sources(exiv2lib PRIVATE localtime.c)
+- target_sources(exiv2 PRIVATE localtime.c)
+ endif()
+
+ if (MSVC)
+ target_sources(exiv2lib PRIVATE getopt_win32.c)
+- target_sources(exiv2 PRIVATE getopt_win32.c)
+ endif()
+
+ # ******************************************************************************