summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 07:16:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 07:51:55 +0100
commit3dc0d41e63809e605cd972f17b7924466e643fb7 (patch)
treed181a9b095cc1dc8389864d7927836183efd4e8c
parentdev-python/trimesh: Bump to 3.19.3 (diff)
downloadgentoo-3dc0d41e.tar.gz
gentoo-3dc0d41e.tar.bz2
gentoo-3dc0d41e.zip
dev-python/Faker: Bump to 16.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Faker/Faker-16.8.1.ebuild33
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-16.8.1.ebuild b/dev-python/Faker/Faker-16.8.1.ebuild
new file mode 100644
index 000000000000..a75f8a9b9b3a
--- /dev/null
+++ b/dev-python/Faker/Faker-16.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 31b2feb98f4a..cafd0243665e 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -5,3 +5,4 @@ DIST Faker-16.4.0.tar.gz 1624299 BLAKE2B 3f3fd6f1ca60c4c481817bcb6f822f265843099
DIST Faker-16.6.0.tar.gz 1625783 BLAKE2B d5a1cd6d8a7161eabf9a36bade94ae0003c5bd4cef48c33b19f6e7a30289267962ec9820cdae85316cb53b16b1a3734d751160db1aa5803ee60c746baa1828c1 SHA512 32f4d8c19ff09c4e415936f458a1ab821be74c4e0e8a79e01d584a8f46ad641b7d873f3a5c2bb3990ffaedb16d0b84eb8a7c610dc6e17b00619045a2c70ed433
DIST Faker-16.6.1.tar.gz 1626043 BLAKE2B 2fc44018b76fffa1f0e249905d20fbc78bc1ab4ffcc3d2448067bfce8c1fd16caf64ce0e073b706a4d0461fd12f4758777a9f9df79b2682a74681dcbcbb7479e SHA512 d2a9add29c6511c452e1ac6749af6772ec5cf0713fe88d773f338f7d1173202bbbc55265e3bbd5cd8d84d9cd4bde153bf614b6840913b704d5c7eed30f4b5512
DIST Faker-16.7.0.tar.gz 1626808 BLAKE2B e2a93903436ee113d76fe5b1403b6e239237c78a64b70b297eb5f5e348a388f7ea681c08f7b60b4ff3bbdcdbdf1a1b348359e690c0c959ec4948b10ec3cec69f SHA512 e3079651d1448dd6a5ff231a1676c00de00703857284c1b5a4261dad2414a84e3cc72891b038bcf52ef9da55075db3b3ee2c742b74832aeaba34bece5a0f8353
+DIST Faker-16.8.1.tar.gz 1649844 BLAKE2B 3ec9b7566342e569580fa8db4df20708ef9b1b6ab0ccdb31b9a33dbe0c7ff3c77ff1b7698e1cf478254d3625d9c516b2b84bcda9bb1d1bdff2161b6d5fcb1056 SHA512 9ea00ec96af0de6a939b9ab3812c75627f2a76514ac6236614d7455b123e4909f9ffe12e9e84f161e0b0b0f2b0f0ddc4ff6661dce788653dd4b8c12098a871fa