summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-05 07:27:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-05 08:07:48 +0200
commit3dc5ac29fc80617d17073c849ba96e83dd16dc68 (patch)
treeb36c03c39208ecbbbb2834fce051f33879d95224
parentdev-python/ruamel-yaml-clib: Bump to 0.2.2 (diff)
downloadgentoo-3dc5ac29fc80617d17073c849ba96e83dd16dc68.tar.gz
gentoo-3dc5ac29fc80617d17073c849ba96e83dd16dc68.tar.bz2
gentoo-3dc5ac29fc80617d17073c849ba96e83dd16dc68.zip
dev-python/testfixtures: Bump to 6.14.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-6.14.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index ed2d29ac656c..f2974f18eee7 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1 +1,2 @@
DIST testfixtures-6.14.1.tar.gz 114969 BLAKE2B 21e6b377e24240cb275feed2e160da256ca75884c5a6dc842364986031c3cd21fb1b5bc13f3e8780354d47179e6c038cb461a39a04d34bfc8beebbf9809d6431 SHA512 0da31d5e382984c22ada846c07570d4a179ba819005dd29891e551b99190fabaaf17174456f7ed4864e9c4aa25f7d5d8b86aa123b4628328610d6930c9c5d6bd
+DIST testfixtures-6.14.2.tar.gz 115229 BLAKE2B 311ef13cc6f596aa9d4c54c0cc02e25c412704eefa3474c3a078f4f50ba556e9872d3ecff3d122443986f0917b2e1c6fff8315d20bd319dec1148fd9851321ba SHA512 fbaeefc439a755d9f9e5ee223c6ce00288adfc2d12c9bef70ab06ea7bc4e9757d7a2429ac8046f7171aca1ac7d667f8a26168cd711f1cc4c719d66bbe8210cc6
diff --git a/dev-python/testfixtures/testfixtures-6.14.2.ebuild b/dev-python/testfixtures/testfixtures-6.14.2.ebuild
new file mode 100644
index 000000000000..e5277b293383
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-6.14.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build, fix Makefile for doc build
+ sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py docs/components.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="." \
+ DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings \
+ pytest -vv || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}