summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-30 21:25:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-28 16:21:01 +0100
commit3dce81ef2a89e49713c924634162ba5abffa0745 (patch)
treea15e3c1b7c0a0b34122f3b4aa319991f43c809d0
parentapp-office/libreoffice-l10n: add 24.2.1.2, drop 24.2.1.1 (diff)
downloadgentoo-3dce81ef2a89e49713c924634162ba5abffa0745.tar.gz
gentoo-3dce81ef2a89e49713c924634162ba5abffa0745.tar.bz2
gentoo-3dce81ef2a89e49713c924634162ba5abffa0745.zip
dev-libs/utfcpp: Rebase onto upstream git master
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/utfcpp/utfcpp-9999.ebuild40
1 files changed, 18 insertions, 22 deletions
diff --git a/dev-libs/utfcpp/utfcpp-9999.ebuild b/dev-libs/utfcpp/utfcpp-9999.ebuild
index 0b15d97bb35e..f92cb7df4237 100644
--- a/dev-libs/utfcpp/utfcpp-9999.ebuild
+++ b/dev-libs/utfcpp/utfcpp-9999.ebuild
@@ -1,41 +1,32 @@
-# Copyright 2015-2022 Gentoo Authors
+# Copyright 2015-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
inherit cmake
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
-
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/nemtrif/utfcpp"
EGIT_SUBMODULES=()
+ inherit git-r3
else
FTEST_GIT_REVISION=""
FTEST_DATE=""
+ SRC_URI="https://github.com/nemtrif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/nemtrif/ftest/archive/${FTEST_GIT_REVISION}.tar.gz -> ftest-${FTEST_DATE}.tar.gz )"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="UTF-8 C++ library"
HOMEPAGE="https://github.com/nemtrif/utfcpp"
-if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/nemtrif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/nemtrif/ftest/archive/${FTEST_GIT_REVISION}.tar.gz -> ftest-${FTEST_DATE}.tar.gz )"
-fi
LICENSE="Boost-1.0"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RESTRICT="!test? ( test )"
-BDEPEND=""
-DEPEND=""
-RDEPEND=""
-
src_unpack() {
- if [[ "${PV}" == "9999" ]]; then
+ if [[ ${PV} == *9999* ]]; then
git-r3_src_unpack
if use test; then
@@ -55,10 +46,15 @@ src_unpack() {
}
src_configure() {
- local mycmakeargs=(
- -DUTF8_SAMPLES=OFF
- -DUTF8_TESTS=$(usex test ON OFF)
- )
-
cmake_src_configure
+
+ pushd tests > /dev/null || die
+ cmake_src_configure
+ popd > /dev/null || die
+}
+
+src_test() {
+ pushd tests > /dev/null || die
+ cmake_src_test
+ popd > /dev/null || die
}