summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-28 18:36:17 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-28 18:36:17 +0100
commit3dd67bd2e5577c45127c428410bb1556498ceafc (patch)
treedad999dd43d0da6df8a34c331b322ea377fd3be9
parentdev-python/setuptools: Version bump (diff)
downloadgentoo-3dd67bd2.tar.gz
gentoo-3dd67bd2.tar.bz2
gentoo-3dd67bd2.zip
dev-python/packaging: Version bump
Gentoo-Bug: 575894 Package-Manager: portage-2.2.27
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-16.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 76e2f4887d73..410e4df5cb1e 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -3,3 +3,4 @@ DIST packaging-16.0.tar.gz 40167 SHA256 a32895134cd7b86ee8add60a3be5bfd7ef3f30e7
DIST packaging-16.1.tar.gz 42929 SHA256 7792caf5bfda630c96310a84ecba5d61b17a843ab72194bb5606d81e4f44094f SHA512 f4e081be85247c989343e7532d5e4afcad68af960264b59271862799e8d63ed0b7fb733670f7446da69aa60f013fc886c8c31c6010c1157110c1a417209d9325 WHIRLPOOL 8c13ef4196633cc4c7c59aef2fa8980abc46908fd30ffbe79d565dcd6089bc1496a8b5dc6aa5968273281e8ef494ef54036c72192f36dfe30dbb0f3fcf8544c9
DIST packaging-16.2.tar.gz 43398 SHA256 0eb4a6329c6d40a0deef725b4f510b6219ec8c365f888583babbb4454d761dd6 SHA512 2310efbd4d73498d5645d0c3a2f0cb162cd18cff28079ba2ac44b784e728363d84a8eae4d9e313c4491394841638ef01ef37ef7da3bac01e27af37a72e387dd1 WHIRLPOOL 5aff538bf5ee18474074048bb581140200c078ceb6366f5c709be931851b0835a8a725ecc17a1b2c34bae34cf79d8743a4422c6701e5c6e9ba99bfdc51aa439f
DIST packaging-16.4.tar.gz 43707 SHA256 325db5b475511303f17e96047877bfc6ba9c895b6850df4a98d95bfbc0329cb1 SHA512 b237352589f8da122246a7222112934e53809c7a04051953c2fb49b2e8910b0ec675105a085187f608a334585d73348f180e855a2ccfa2d590dd38fa65260a70 WHIRLPOOL 4f9d0f20c7eeb0d1a9f3086c91df780bfff3d0062f69c08c6c70d4e288e83b79aa2ab38e9bbb82dbdc607c2b48e45760bbe53d390d4f431f714e63396d33c4de
+DIST packaging-16.5.tar.gz 43810 SHA256 b763bd2a025e957323f761bf00fb72e8c17ac1c6d5eb8fb55c18802f2143f911 SHA512 60d4317f5a86518078d56a08a3121536ba2ed2232dfc44c7962aa0e17676c7116c25f710ff2056ca44a0f1b0db15e5f02d6f785f9db0ab3af613b2056430a6f3 WHIRLPOOL bdd83eb84af57dfc81aa318966b43b98f6915e7a81a6b3ae019c294cfb687a0fd491e84c8f15a3ae23d9568292f7c111ab4f17ff7e200ba4d1700e953bbf4fca
diff --git a/dev-python/packaging/packaging-16.5.ebuild b/dev-python/packaging/packaging-16.5.ebuild
new file mode 100644
index 000000000000..26279ce494d2
--- /dev/null
+++ b/dev-python/packaging/packaging-16.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ py.test --capture=no --strict -v || die
+}
+
+pkg_preinst() {
+ # Remove this in the next version bump
+ _cleanup() {
+ local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
+ local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
+ if [[ -d ${egginfo} ]]; then
+ echo rm -r "${egginfo}"
+ rm -r "${egginfo}" || die "Failed to remove egg-info directory"
+ fi
+ }
+ python_foreach_impl _cleanup
+}