summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-28 15:05:22 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-01 23:23:46 +0200
commit3deefe2d619c81c08825d79a6efefc3f75d2b266 (patch)
treeb8da4326234d020d7d6fc580c194bb03cf8d6307
parentdev-python/eyeD3: bump to python 3.10 (diff)
downloadgentoo-3deefe2d619c81c08825d79a6efefc3f75d2b266.tar.gz
gentoo-3deefe2d619c81c08825d79a6efefc3f75d2b266.tar.bz2
gentoo-3deefe2d619c81c08825d79a6efefc3f75d2b266.zip
dev-python/pytest-tempdir: bump to python 3.10
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild13
1 files changed, 2 insertions, 11 deletions
diff --git a/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild b/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild
index f347e2e070f7..0720ff8875bd 100644
--- a/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild
+++ b/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Pytest plugin to support for a predictable and repeatable temporary directory"
@@ -14,13 +14,4 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
-BDEPEND="
- >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests --install pytest