summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-10 09:17:42 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-10 09:17:52 +0100
commit3e0c77ac812b88cb421ec994fb852b8d7d5581a4 (patch)
tree6ecce255fed66dee40a49ea6e95f0b96c732f8a8
parentdev-db/jxtray: Removal. Fixes bug 402757. (diff)
downloadgentoo-3e0c77ac812b88cb421ec994fb852b8d7d5581a4.tar.gz
gentoo-3e0c77ac812b88cb421ec994fb852b8d7d5581a4.tar.bz2
gentoo-3e0c77ac812b88cb421ec994fb852b8d7d5581a4.zip
dev-python/gst-python: Adopt to changes in general python handling
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=567902 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/gst-python/gst-python-1.2.1.ebuild8
-rw-r--r--dev-python/gst-python/gst-python-1.4.0.ebuild8
-rw-r--r--dev-python/gst-python/gst-python-1.6.0.ebuild8
-rw-r--r--dev-python/gst-python/gst-python-1.6.1.ebuild8
4 files changed, 28 insertions, 4 deletions
diff --git a/dev-python/gst-python/gst-python-1.2.1.ebuild b/dev-python/gst-python/gst-python-1.2.1.ebuild
index b2da6fdcd235..eeb014cfe529 100644
--- a/dev-python/gst-python/gst-python-1.2.1.ebuild
+++ b/dev-python/gst-python/gst-python-1.2.1.ebuild
@@ -38,8 +38,14 @@ src_prepare() {
python_foreach_impl prepare_gst
}
+myeconf() {
+ local flag
+ flag="$(${PYTHON} -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS") or "")')"
+ PYTHON="${EPYTHON}${flag}" econf
+}
+
src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir myeconf
}
src_compile() {
diff --git a/dev-python/gst-python/gst-python-1.4.0.ebuild b/dev-python/gst-python/gst-python-1.4.0.ebuild
index 03861fd7efc7..80b1de329767 100644
--- a/dev-python/gst-python/gst-python-1.4.0.ebuild
+++ b/dev-python/gst-python/gst-python-1.4.0.ebuild
@@ -34,8 +34,14 @@ src_prepare() {
python_foreach_impl prepare_gst
}
+myeconf() {
+ local flag
+ flag="$(${PYTHON} -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS") or "")')"
+ PYTHON="${EPYTHON}${flag}" econf
+}
+
src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir myeconf
}
src_compile() {
diff --git a/dev-python/gst-python/gst-python-1.6.0.ebuild b/dev-python/gst-python/gst-python-1.6.0.ebuild
index 53128bc120af..81d086d622ad 100644
--- a/dev-python/gst-python/gst-python-1.6.0.ebuild
+++ b/dev-python/gst-python/gst-python-1.6.0.ebuild
@@ -34,8 +34,14 @@ src_prepare() {
python_foreach_impl prepare_gst
}
+myeconf() {
+ local flag
+ flag="$(${PYTHON} -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS") or "")')"
+ PYTHON="${EPYTHON}${flag}" econf
+}
+
src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir myeconf
}
src_compile() {
diff --git a/dev-python/gst-python/gst-python-1.6.1.ebuild b/dev-python/gst-python/gst-python-1.6.1.ebuild
index d4659611ea70..95d223e2ed34 100644
--- a/dev-python/gst-python/gst-python-1.6.1.ebuild
+++ b/dev-python/gst-python/gst-python-1.6.1.ebuild
@@ -35,8 +35,14 @@ src_prepare() {
python_foreach_impl prepare_gst
}
+myeconf() {
+ local flag
+ flag="$(${PYTHON} -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS") or "")')"
+ PYTHON="${EPYTHON}${flag}" econf
+}
+
src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir myeconf
}
src_compile() {