summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 22:13:08 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 22:13:08 +0100
commit3e30db72e8c0e6dd864cd6042171b3f3d7de38bc (patch)
treed926de31062925f3a2321397e99c8c54b35128d2
parentdev-python/pycups: Switch to PEP 517 build (diff)
downloadgentoo-3e30db72e8c0e6dd864cd6042171b3f3d7de38bc.tar.gz
gentoo-3e30db72e8c0e6dd864cd6042171b3f3d7de38bc.tar.bz2
gentoo-3e30db72e8c0e6dd864cd6042171b3f3d7de38bc.zip
dev-python/pydecomp: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pydecomp/pydecomp-0.3-r3.ebuild27
-rw-r--r--dev-python/pydecomp/pydecomp-9999.ebuild4
2 files changed, 29 insertions, 2 deletions
diff --git a/dev-python/pydecomp/pydecomp-0.3-r3.ebuild b/dev-python/pydecomp/pydecomp-0.3-r3.ebuild
new file mode 100644
index 000000000000..145b4f654392
--- /dev/null
+++ b/dev-python/pydecomp/pydecomp-0.3-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://github.com/dol-sen/pyDeComp.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/pyDeComp-${PV}"
+fi
+
+DESCRIPTION="A python library of common (de)compression and contents handling"
+HOMEPAGE="https://github.com/dol-sen/pyDeComp"
+
+LICENSE="BSD"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PV}-no-pixz-index.patch" )
diff --git a/dev-python/pydecomp/pydecomp-9999.ebuild b/dev-python/pydecomp/pydecomp-9999.ebuild
index 007ab948ae8d..8266a320a04b 100644
--- a/dev-python/pydecomp/pydecomp-9999.ebuild
+++ b/dev-python/pydecomp/pydecomp-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1