summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-06-26 14:22:41 +0200
committerHans de Graaff <graaff@gentoo.org>2020-06-26 14:42:01 +0200
commit3e468f21b9f3d83a45d0498a02921f8503ccac15 (patch)
tree95c0183293f9eed5c6d995978ea6410524635597
parentdev-ruby/vcr: cleanup (diff)
downloadgentoo-3e468f21.tar.gz
gentoo-3e468f21.tar.bz2
gentoo-3e468f21.zip
dev-ruby/vcr: add json USE flag
Add support for casettes serialized in JSON by adding the required dependency for it. Bug: https://bugs.gentoo.org/729484 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/vcr/metadata.xml3
-rw-r--r--dev-ruby/vcr/vcr-4.0.0.ebuild8
-rw-r--r--dev-ruby/vcr/vcr-5.1.0.ebuild4
-rw-r--r--dev-ruby/vcr/vcr-6.0.0.ebuild4
4 files changed, 14 insertions, 5 deletions
diff --git a/dev-ruby/vcr/metadata.xml b/dev-ruby/vcr/metadata.xml
index 3e7ac4fc6b7b..588668ce56b8 100644
--- a/dev-ruby/vcr/metadata.xml
+++ b/dev-ruby/vcr/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="github">myronmarston/vcr</remote-id>
</upstream>
+ <use>
+ <flag name="json">Add support for casettes serialized with JSON</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-ruby/vcr/vcr-4.0.0.ebuild b/dev-ruby/vcr/vcr-4.0.0.ebuild
index cae5212ae316..096a7318138b 100644
--- a/dev-ruby/vcr/vcr-4.0.0.ebuild
+++ b/dev-ruby/vcr/vcr-4.0.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+USE_RUBY="ruby24 ruby25 ruby26"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md README.md Upgrade.md"
@@ -16,8 +16,10 @@ LICENSE="MIT"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~x86"
SLOT="3"
-IUSE="test"
+IUSE="json test"
# Tests require all supported HTTP libraries to be present, and it is
# not possible to avoid some of them without very extensive patches.
RESTRICT="test"
+
+ruby_add_rdepend "json? ( dev-ruby/multi_json )"
diff --git a/dev-ruby/vcr/vcr-5.1.0.ebuild b/dev-ruby/vcr/vcr-5.1.0.ebuild
index ca4669a2923a..c6e6cd0a24d1 100644
--- a/dev-ruby/vcr/vcr-5.1.0.ebuild
+++ b/dev-ruby/vcr/vcr-5.1.0.ebuild
@@ -17,8 +17,10 @@ LICENSE="MIT"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
SLOT="$(ver_cut 1)"
-IUSE="test"
+IUSE="json test"
# Tests require all supported HTTP libraries to be present, and it is
# not possible to avoid some of them without very extensive patches.
RESTRICT="test"
+
+ruby_add_rdepend "json? ( dev-ruby/multi_json )"
diff --git a/dev-ruby/vcr/vcr-6.0.0.ebuild b/dev-ruby/vcr/vcr-6.0.0.ebuild
index ca4669a2923a..9df479fba6a9 100644
--- a/dev-ruby/vcr/vcr-6.0.0.ebuild
+++ b/dev-ruby/vcr/vcr-6.0.0.ebuild
@@ -17,8 +17,10 @@ LICENSE="MIT"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
SLOT="$(ver_cut 1)"
-IUSE="test"
+IUSE="json test"
# Tests require all supported HTTP libraries to be present, and it is
# not possible to avoid some of them without very extensive patches.
RESTRICT="test"
+
+ruby_add_rdepend "json? ( dev-ruby/json )"