summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-17 21:23:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-17 21:23:17 +0300
commit3e5b44c6a367fa731a72750e2987e1b069c24c8a (patch)
treea9e8633d34cd32065d71ba9fff49b7a8d3f7ee7d
parentdev-python/matplotlib-inline: enable py3.11 (diff)
downloadgentoo-3e5b44c6.tar.gz
gentoo-3e5b44c6.tar.bz2
gentoo-3e5b44c6.zip
dev-python/libtmux: add 0.14.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.14.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 4cbadf022712..30e7a86c7751 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -1,5 +1,6 @@
DIST libtmux-0.12.0.gh.tar.gz 214161 BLAKE2B 7040da2ee782b2e6bc73c70de0f5d5713c989a0959b0e731ac060f442e82e99829689f924cc2aeef6e79339b4f419df4143e2d5a9e356ad27cccb9cb3802e2f2 SHA512 f6f80daa3aaa99dd81ec0eb6a119ab1ad5fcd6c656d280b06a40c2b3bdc8d3ca7ae06089ea74482bfff005997f07e346338330d9ecf1c6745a6f3b7719b9cd0a
DIST libtmux-0.13.0.gh.tar.gz 240339 BLAKE2B 5b975bef4835ed8b74f05fd56bd824028fa64b56c700396d0387661cdf41a4a43d81dce10462c89a90ce352b00ca0fea0334fa02e7259464a62369637b2435ce SHA512 bc5fce8c201f7c69fcbc15605808544baf19896e51c44daeebc4c133ee1db70dbffa8eea2641862cf27ca9fe341f4721cde432682e5aea84b2573f83ad25555f
DIST libtmux-0.14.0.gh.tar.gz 241472 BLAKE2B 910005f944eefc8e7a92e476fb5d6c1693b1d1a6a82a27445487b9d16037610d6bd79301dea3c14a3be297ff8c774ba9e80f2036b6cf6259822c31ff673eaacf SHA512 726df5781a6c1a80f31035c6dda6e423e30c49d7d6e9865cfb17777a96dc36cc4a4f22f1330a87d3d1fa2f513ac34a7e1c4a51c9bd3dc1d2be79c67767061b76
+DIST libtmux-0.14.2.gh.tar.gz 234682 BLAKE2B e93b0a280c3cfdfab4c9a313d251d15665c530813f00aa78151efe62a6a566f2d8986afed015de4a8be80b48f31ac197e98d3efa592eb8895e8d9626ff34ef72 SHA512 1565529ecf555dac8f896146e2d802c0e5460458ea1da6ba5496d5d2c394f56cc8c5f7650c5d4aebd1750659bbdc529e439e60dff6a0ccef8806bb65305d2421
DIST libtmux-v0.10.3.tar.gz 225258 BLAKE2B 40d591ee1f8a6068947b61416d6247b2475cc99031a67c167dc527631e50075f18c46fe6fc16193867d83a1a735b0a23fbfbc77f4539f788f05375f1f68b77d2 SHA512 2c8f28ce8c313404caffa42e5fd4a1dfa5d48bdc48203f8db595cb97b44886d63608771f23d62d76a56513b7e4578e48a31cacd224eca92425f110efd0a5db69
DIST libtmux-v0.11.0.tar.gz 234278 BLAKE2B 4939d38894fd6a1492ff282c98243b2d5b3b6f787691031c74337629aed710d3caebeb3bfce571e8f38fe07ecc341b6b3f8aa0bc42979fa362f5f0679aabf21e SHA512 e09749ce4cf7cf7756e4e40e50c6eb0a00435f2b00c8436667b6b77a94078e9c380a811107f8129ea0d347355f3ce8bb213b8fb36de2becf3cf1a2dbebd97867
diff --git a/dev-python/libtmux/libtmux-0.14.2.ebuild b/dev-python/libtmux/libtmux-0.14.2.ebuild
new file mode 100644
index 000000000000..be24d300e9a1
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.14.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="
+ https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ libtmux/pane.py::libtmux.pane.Pane.send_keys
+)
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ distutils-r1_python_prepare_all
+}