summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 00:04:44 -0500
committerSam James <sam@gentoo.org>2024-02-29 05:44:22 +0000
commit3e5ea66341d6dbe439b41ea0cfe9c16ac8ab4763 (patch)
treeee0670409ed1ca8296000ca41e34b6735a6e6fc8
parentmedia-video/ffmpeg: fix crash when CPU_FLAGS_x86 and CFLAGS disagree (diff)
downloadgentoo-3e5ea66341d6dbe439b41ea0cfe9c16ac8ab4763.tar.gz
gentoo-3e5ea66341d6dbe439b41ea0cfe9c16ac8ab4763.tar.bz2
gentoo-3e5ea66341d6dbe439b41ea0cfe9c16ac8ab4763.zip
net-print/hplip: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/861851 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-print/hplip/hplip-3.23.12-r1.ebuild7
-rw-r--r--net-print/hplip/hplip-3.23.12.ebuild9
2 files changed, 13 insertions, 3 deletions
diff --git a/net-print/hplip/hplip-3.23.12-r1.ebuild b/net-print/hplip/hplip-3.23.12-r1.ebuild
index 8981b1c837fb..e1ab49564e06 100644
--- a/net-print/hplip/hplip-3.23.12-r1.ebuild
+++ b/net-print/hplip/hplip-3.23.12-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10,11} )
PYTHON_REQ_USE="threads(+),xml(+)"
-inherit autotools linux-info python-single-r1 readme.gentoo-r1 udev
+inherit autotools flag-o-matic linux-info python-single-r1 readme.gentoo-r1 udev
DESCRIPTION="HP Linux Imaging and Printing - Print, scan, fax drivers and service tools"
HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing"
@@ -141,6 +141,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/861851
+ # https://bugs.launchpad.net/hplip/+bug/2055371
+ filter-lto
+
local drv_build minimal_build
if use hpcups ; then
diff --git a/net-print/hplip/hplip-3.23.12.ebuild b/net-print/hplip/hplip-3.23.12.ebuild
index 7b4a0c432646..e9658aec1aff 100644
--- a/net-print/hplip/hplip-3.23.12.ebuild
+++ b/net-print/hplip/hplip-3.23.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10,11} )
PYTHON_REQ_USE="threads(+),xml(+)"
-inherit autotools linux-info python-single-r1 readme.gentoo-r1 udev
+inherit autotools flag-o-matic linux-info python-single-r1 readme.gentoo-r1 udev
DESCRIPTION="HP Linux Imaging and Printing - Print, scan, fax drivers and service tools"
HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing"
@@ -141,6 +141,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/861851
+ # https://bugs.launchpad.net/hplip/+bug/2055371
+ filter-lto
+
local drv_build minimal_build
if use hpcups ; then