summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-11 19:10:58 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-11 19:10:58 -0400
commit3e6bb6a18403b4f81d6f163e93957d2642b67611 (patch)
treee8513421b6cb0f8de132af1e8cb047fcbfd89059
parentdev-python/kitchen: version bump. (diff)
downloadgentoo-3e6bb6a1.tar.gz
gentoo-3e6bb6a1.tar.bz2
gentoo-3e6bb6a1.zip
dev-python/txaio: remove spurious dependencies and phase
* app-arch/unzip is uneeded (SRC_URI is a tarball) * tox, pep8, pytest-cov and pyenchant are uneeded to run tests * No need to patch in "utils.py" anymore Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--dev-python/txaio/txaio-2.9.0.ebuild15
1 files changed, 2 insertions, 13 deletions
diff --git a/dev-python/txaio/txaio-2.9.0.ebuild b/dev-python/txaio/txaio-2.9.0.ebuild
index 62ffde7501e8..eff2bf41f96e 100644
--- a/dev-python/txaio/txaio-2.9.0.ebuild
+++ b/dev-python/txaio/txaio-2.9.0.ebuild
@@ -19,7 +19,7 @@ RDEPEND="
$(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' python2_7)
$(python_gen_cond_dep '>=dev-python/futures-3.0.3[${PYTHON_USEDEP}]' python2_7)
"
-DEPEND="app-arch/unzip
+DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
doc? (
@@ -28,11 +28,7 @@ DEPEND="app-arch/unzip
>=dev-python/sphinx_rtd_theme-0.1.9[${PYTHON_USEDEP}]
)
test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
>=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/tox-2.1.1[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/pyenchant-1.6.6[${PYTHON_USEDEP}]
)
"
@@ -43,19 +39,12 @@ src_prepare() {
rm "${S}/test/test_packaging.py" || die
}
-python_prepare() {
- # https://github.com/tavendo/txaio/issues/3
- cp -r "${FILESDIR}"/util.py test || die
-
- distutils-r1_python_prepare
-}
-
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
+ pytest -v || die "Tests failed under ${EPYTHON}"
}
python_install_all() {