summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-01-02 04:21:39 +0200
committerStefan Strogin <steils@gentoo.org>2020-01-02 04:25:32 +0200
commit3e758a76a1ecef8d224e11a208db33f6f69b9451 (patch)
tree27a2da51a25e0ee40dd995f65a801a657dedb014
parentnet-analyzer/cbm: Version 0.2 (diff)
downloadgentoo-3e758a76a1e.tar.gz
gentoo-3e758a76a1e.tar.bz2
gentoo-3e758a76a1e.zip
games-util/lutris: add patch to fix issue with x11-libs/gtk+-3.24.13
Reported-by: Marcin Woźniak <y0rune@aol.com> Closes: https://bugs.gentoo.org/704130 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--games-util/lutris/files/lutris-0.5.4-gtk.patch29
-rw-r--r--games-util/lutris/lutris-0.5.4-r1.ebuild (renamed from games-util/lutris/lutris-0.5.4.ebuild)4
2 files changed, 32 insertions, 1 deletions
diff --git a/games-util/lutris/files/lutris-0.5.4-gtk.patch b/games-util/lutris/files/lutris-0.5.4-gtk.patch
new file mode 100644
index 000000000000..a2c5d71d9982
--- /dev/null
+++ b/games-util/lutris/files/lutris-0.5.4-gtk.patch
@@ -0,0 +1,29 @@
+From a97150b78954e176cb0f825f0c201f54d5da613e Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <steils@gentoo.org>
+Date: Tue, 31 Dec 2019 03:22:26 +0200
+Subject: [PATCH] Call the correct method for creating TreeModelSort (Closes
+ #2554)
+
+Upstream-Status: Accepted
+[https://github.com/lutris/lutris/commit/a99b17f00dfc4cdab80c237752cc3167d64194eb]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ lutris/gui/views/store.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lutris/gui/views/store.py b/lutris/gui/views/store.py
+index ba331313..4d5f372e 100644
+--- a/lutris/gui/views/store.py
++++ b/lutris/gui/views/store.py
+@@ -130,7 +130,7 @@ class GameStore(GObject.Object):
+ self.prevent_sort_update = False # prevent recursion with signals
+ self.modelfilter = self.store.filter_new()
+ self.modelfilter.set_visible_func(self.filter_view)
+- self.modelsort = Gtk.TreeModelSort.sort_new_with_model(self.modelfilter)
++ self.modelsort = Gtk.TreeModelSort.new_with_model(self.modelfilter)
+ self.modelsort.connect("sort-column-changed", self.on_sort_column_changed)
+ self.modelsort.set_sort_func(sort_col, sort_func, sort_col)
+ self.sort_view(sort_key, sort_ascending)
+--
+2.24.1
+
diff --git a/games-util/lutris/lutris-0.5.4.ebuild b/games-util/lutris/lutris-0.5.4-r1.ebuild
index 7eb0bd47ed17..e84a25660474 100644
--- a/games-util/lutris/lutris-0.5.4.ebuild
+++ b/games-util/lutris/lutris-0.5.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,6 +49,8 @@ RDEPEND="
x11-libs/libnotify
"
+PATCHES=( "${FILESDIR}/${P}-gtk.patch" )
+
python_install_all() {
local DOCS=( AUTHORS README.rst docs/installers.rst )
distutils-r1_python_install_all