summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-29 11:24:54 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-29 12:08:35 -0400
commit3e7d521c3d77ad1e7bc4b472128e56c6ac68f9ac (patch)
tree7fa3a63630de6803f2f661df37d6a0e3044a7a29
parentapp-containers/syft: revbump for arm64 and version fix (diff)
downloadgentoo-3e7d521c3d77ad1e7bc4b472128e56c6ac68f9ac.tar.gz
gentoo-3e7d521c3d77ad1e7bc4b472128e56c6ac68f9ac.tar.bz2
gentoo-3e7d521c3d77ad1e7bc4b472128e56c6ac68f9ac.zip
app-accessibility/accerciser: Version bump to 3.40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-accessibility/accerciser/Manifest1
-rw-r--r--app-accessibility/accerciser/accerciser-3.40.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
index 7b54af672b6b..6eba941924c2 100644
--- a/app-accessibility/accerciser/Manifest
+++ b/app-accessibility/accerciser/Manifest
@@ -1 +1,2 @@
DIST accerciser-3.38.0.tar.xz 2006380 BLAKE2B 8a073e3a933386c9ae46d71535a3a49930bf8100d1458ac1875e1bcb69acc13e2331ac568c566ec6b8fe8ff9836155cc2ff20558de0e21942a29a568ff916fa5 SHA512 5740e4acfb00f5842dac8045ca9f10c85cf2ae164f3e0caf63ec303ff104002ace6de591a9b6516c4052ec0da8e48b394647f018b6c8b68a6c5ff77c4fff2904
+DIST accerciser-3.40.0.tar.xz 1991256 BLAKE2B adcaa37b64d91cf4348fdd1b15d22aa977585c2c9d3ad81b41c7711f82ce010c7b75a44de6ec780fbbdadacad856a1f15b4f492971f5a7acfcea0568f0edc2df SHA512 78a7ce4a69de9a237c75b8df25665c8e9e8173969fb146cb608f4b51ff042c3abdcd49225f8f420c1c1bfab3736a8607eb6b555106c8a1e6e3399c83bad8f198
diff --git a/app-accessibility/accerciser/accerciser-3.40.0.ebuild b/app-accessibility/accerciser/accerciser-3.40.0.ebuild
new file mode 100644
index 000000000000..cfedba6402c8
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.40.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser https://gitlab.gnome.org/GNOME/accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ ')
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection:=
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ gnome-base/librsvg[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}