summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-07 01:17:48 +0000
committerSam James <sam@gentoo.org>2022-02-07 01:21:43 +0000
commit3e846fa4b82dbcba6025faffcde18ee6bdea4b3c (patch)
treeda36af79e60aa82006824f50f776d908752c3146
parentsys-libs/gdbm: add 1.23 (diff)
downloadgentoo-3e846fa4b82dbcba6025faffcde18ee6bdea4b3c.tar.gz
gentoo-3e846fa4b82dbcba6025faffcde18ee6bdea4b3c.tar.bz2
gentoo-3e846fa4b82dbcba6025faffcde18ee6bdea4b3c.zip
sys-apps/ed: add 1.18
Go back to using lzip. Upstream only provide lzip archives (and indeed the maintainer of ed is the maintainer of lzip) and repacking to avoid a BDEPEND for a relatively unpopular package is overkill. Bug: https://bugs.gentoo.org/545344 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/ed/Manifest1
-rw-r--r--sys-apps/ed/ed-1.18.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/ed/Manifest b/sys-apps/ed/Manifest
index 7d34d8566af4..f23f3129b7e6 100644
--- a/sys-apps/ed/Manifest
+++ b/sys-apps/ed/Manifest
@@ -1 +1,2 @@
DIST ed-1.17.tar.xz 68516 BLAKE2B 975e6547f0062dc980bf4490bbbc98e0ac77fc18b2960e18a4c86a6c9190dbd6e1afb155678a1b7d891dc6cb1c5f5c07612365bbf3ffae15bf7575989e4b67d7 SHA512 ebe755ea7d12a7f54379ad8e03b703e9c0dd9aec26b4a79e5014db4368ab2d2926ae094f2ef1aef90cc9b2d541746a81af472578fa44cdf5bfe78aff5882451d
+DIST ed-1.18.tar.lz 66019 BLAKE2B 9f2b6f00e65dc8a13dd9eba4dfae5ad1e6e3c3ffe623c8b2cc2db78e221ba140595658fd710e4651165a2475a9ed673c9f230fab64f22a7a9488973b5e227198 SHA512 e5dac94697d63fb90cc17e3e653fa56309e9652cc25b2e98a0e21f1ed41e38c48bc33b5fc746275a59e702d1644d3af88f3d82598b482f7309f4e68aab783286
diff --git a/sys-apps/ed/ed-1.18.ebuild b/sys-apps/ed/ed-1.18.ebuild
new file mode 100644
index 000000000000..701bffec7605
--- /dev/null
+++ b/sys-apps/ed/ed-1.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs unpacker
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="https://www.gnu.org/software/ed/"
+SRC_URI="mirror://gnu/ed/${P}.tar.lz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+if [[ "${PV}" != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+BDEPEND="sys-apps/texinfo
+ $(unpacker_src_uri_depends)"
+
+src_configure() {
+ ./configure \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ --bindir="${EPREFIX}/bin" \
+ --prefix="${EPREFIX}/usr" || die
+}