summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-06-03 07:31:31 +0200
committerHans de Graaff <graaff@gentoo.org>2018-06-03 07:31:31 +0200
commit3e8a3b48c726b99015a0411cd1a59d6367c7f9d8 (patch)
tree402164679e353e0a95af28077f8fd8579ce17e86
parentapp-emacs/magit: add 2.13.0 (diff)
downloadgentoo-3e8a3b48.tar.gz
gentoo-3e8a3b48.tar.bz2
gentoo-3e8a3b48.zip
dev-ruby/webrobots: add ruby25 and missing vcr dependency
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-ruby/webrobots/webrobots-0.1.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/webrobots/webrobots-0.1.2-r1.ebuild b/dev-ruby/webrobots/webrobots-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..413984e979ad
--- /dev/null
+++ b/dev-ruby/webrobots/webrobots-0.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to help write robots.txt compliant web robots"
+HOMEPAGE="https://github.com/knu/webrobots"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/test-unit:2 dev-ruby/webmock dev-ruby/vcr )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/d' Rakefile test/helper.rb || die
+
+ # Avoid tests for live websites requirering a network connection.
+ sed -i -e '/robots.txt in the real world/,/^ end/ s:^:#:' test/test_webrobots.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}