summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-20 20:15:43 -0400
committerMichael Palimaka <kensington@gentoo.org>2017-07-22 13:35:00 +1000
commit3e9efb7e12ea706f8ed75e7cb66747d3c798111b (patch)
treedbf756079ac44884ad7f1e9ac2eaadd03780ea06
parentx11-wm/compiz-fusion: remove 0.8.8-r0 (diff)
downloadgentoo-3e9efb7e.tar.gz
gentoo-3e9efb7e.tar.bz2
gentoo-3e9efb7e.zip
games-mud/kmuddy: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=612760 Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--games-mud/kmuddy/files/kmuddy-1.0.1-gcc6.patch30
-rw-r--r--games-mud/kmuddy/kmuddy-1.0.1-r3.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/games-mud/kmuddy/files/kmuddy-1.0.1-gcc6.patch b/games-mud/kmuddy/files/kmuddy-1.0.1-gcc6.patch
new file mode 100644
index 000000000000..a198d141b10e
--- /dev/null
+++ b/games-mud/kmuddy/files/kmuddy-1.0.1-gcc6.patch
@@ -0,0 +1,30 @@
+Bug: https://bugs.gentoo.org/612760
+Commits: https://cgit.kde.org/kmuddy.git/commit/kmuddy/dialogs/dlgappsettings.cpp?id=5def190b6b3baa7502999275aac469440ec261cc
+ https://cgit.kde.org/kmuddy.git/commit/plugins/mapper/dialogs/dlgmappathproperties.cpp?id=0255f21b46a0f83e2e455fd2ba5c015a3b46e98a
+
+--- a/kmuddy/dialogs/dlgappsettings.cpp
++++ b/kmuddy/dialogs/dlgappsettings.cpp
+@@ -554,7 +554,7 @@
+ //page 8
+ //layout ensures that the widget fills entire available space...
+ QHBoxLayout *keylayout = new QHBoxLayout (frmshortcuts);
+- keys = new KShortcutsEditor (cActionManager::self()->getACol (), frmshortcuts, false);
++ keys = new KShortcutsEditor (cActionManager::self()->getACol (), frmshortcuts);
+ keylayout->addWidget (keys);
+
+ cActionManager::self()->invokeEvent ("dialog-create", 0, "app-prefs");
+--- a/plugins/mapper/dialogs/dlgmappathproperties.cpp
++++ b/plugins/mapper/dialogs/dlgmappathproperties.cpp
+@@ -242,9 +242,9 @@
+ {
+ properties.writeEntry("SrcBeforeCommand",txtSrcBefore->text().trimmed());
+ properties.writeEntry("SrcAfterCommand",txtSrcAfter->text().trimmed());
+- properties.writeEntry("SrcDir",(int)getSrcDirection(),0);
+- properties.writeEntry("DestDir",(int)getDestDirection(),0);
+- properties.writeEntry("SpecialExit",chkSpecial->isChecked(),false);
++ properties.writeEntry("SrcDir",(int)getSrcDirection());
++ properties.writeEntry("DestDir",(int)getDestDirection());
++ properties.writeEntry("SpecialExit",chkSpecial->isChecked());
+ properties.writeEntry("SpecialCmdSrc",txtSpecialSrc->text().trimmed());
+
+ if (properties.hasKey("PathTwoWay"))
diff --git a/games-mud/kmuddy/kmuddy-1.0.1-r3.ebuild b/games-mud/kmuddy/kmuddy-1.0.1-r3.ebuild
index a40866d7460a..b6aeffc39105 100644
--- a/games-mud/kmuddy/kmuddy-1.0.1-r3.ebuild
+++ b/games-mud/kmuddy/kmuddy-1.0.1-r3.ebuild
@@ -25,6 +25,7 @@ PATCHES=(
"${FILESDIR}"/${P}-underlinking.patch
"${FILESDIR}"/${P}-tempnam.patch
"${FILESDIR}"/${P}-desktopvalidation.patch
+ "${FILESDIR}"/${P}-gcc6.patch
)
src_configure() {