summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-01 09:55:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-11-01 10:00:19 -0400
commit3eb67faf3b499bc30401e718f9a80bcc0413b40a (patch)
treea287ff5bf130119c4b07cc022480eaf8d954235a
parentwww-client/qutebrowser: revert to back to old verify-sig handling (diff)
downloadgentoo-3eb67faf3b499bc30401e718f9a80bcc0413b40a.tar.gz
gentoo-3eb67faf3b499bc30401e718f9a80bcc0413b40a.tar.bz2
gentoo-3eb67faf3b499bc30401e718f9a80bcc0413b40a.zip
x11-terms/kitty: revert back to old verify-sig handling
Does not change much in this case (need src_unpack either way), but if no longer need to pass BROOT then would rather keep the variable where it's typically found (otherwise this is the only ebuild in the tree using this as a local variable). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty/kitty-0.30.1.ebuild5
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/x11-terms/kitty/kitty-0.30.1.ebuild b/x11-terms/kitty/kitty-0.30.1.ebuild
index e8ed6e9ed433..aa40b2f334ac 100644
--- a/x11-terms/kitty/kitty-0.30.1.ebuild
+++ b/x11-terms/kitty/kitty-0.30.1.ebuild
@@ -16,6 +16,7 @@ else
https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
"
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
fi
@@ -86,10 +87,8 @@ src_unpack() {
cd "${S}" || die
edo go mod vendor
else
- if use verify-sig; then
- local VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ use verify-sig &&
verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
- fi
default
fi
}
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index bcc646853001..b36e8889ca4f 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -16,6 +16,7 @@ else
https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
"
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
@@ -86,10 +87,8 @@ src_unpack() {
cd "${S}" || die
edo go mod vendor
else
- if use verify-sig; then
- local VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ use verify-sig &&
verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
- fi
default
fi
}