summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-08 07:10:55 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-08 07:38:25 +0100
commit3eb9f0600a286ca3f5d8f79a122c3708088a307c (patch)
treeaba266d137041b310a6112d2b3eba651debc8565
parentapp-admin/awscli: Bump to 1.29.80 (diff)
downloadgentoo-3eb9f0600a286ca3f5d8f79a122c3708088a307c.tar.gz
gentoo-3eb9f0600a286ca3f5d8f79a122c3708088a307c.tar.bz2
gentoo-3eb9f0600a286ca3f5d8f79a122c3708088a307c.zip
dev-python/trimesh: Bump to 4.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.0.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index a2b2c3e1b6bd..923ab0a531fe 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -2,3 +2,4 @@ DIST trimesh-3.23.5.gh.tar.gz 12720153 BLAKE2B ef37eed712eb121529bf6bc724f96456a
DIST trimesh-4.0.0.gh.tar.gz 12921048 BLAKE2B 7592ba10b57aa5cafd47311a430f881cc1ecc917f503e0cea75b38d350738d35c937e1006f80a0acc8a54a33e55f41af3d6cf280751b82a932bd2428af12e033 SHA512 1f5c1a3e92d6bda2ed37e5c6ece9fde798a2c2766c816cbb6a8bf9fdbf489f733ea3988429107eb92043f723bc222348ffe9286663a03562834ae83391793257
DIST trimesh-4.0.1.gh.tar.gz 12922631 BLAKE2B 81cad4efea89c308f9cbb749b2515ed51f9fc87bbd37505ab94c08698f257c7f3a1b04e1b4a919bf529ee47d7531ecd605dd613c68b13fdaf853161811dfd1e6 SHA512 bfe56b3cfc94fcaa066b953e6df4c70da6fe9a99a6230d7201196a7df897a386c3425ad1da3cc7df75fa0d888fd05d07bf14e6b579a04dddab813c3858f904ef
DIST trimesh-4.0.2.gh.tar.gz 13433444 BLAKE2B a466adc4708e7f59cb7a64f3872df89888ad21a4f78520c5f109c101ea5d42973705e59807dd800058f3925744a30cc6ddd88fa498533f7e69255ba0c5d652e2 SHA512 7c0c8cbf40f03f4fd92156306f0a0d4d0a1dbf774c9a1743d63d82be2264b50915f2f6ea2cdebd0e81390e7f96acb47eca9980f3829311ec027706ef1cc143c0
+DIST trimesh-4.0.3.gh.tar.gz 13434060 BLAKE2B 7777498fbf4fdfac221c6f6226e4c5554de593ff2c41877dd88df2e0f674dd4dcf8bb0e83fa4a9c81cc2ea0f970cc848ef1380b734231ba8965f61acde28678b SHA512 1eec21e3bcbc80f7ea939b16753ac24d45d750c176044d57a5c2217d46a1559478ab260147e82b1367df7dcb9ecf9aa11dda3a023ebb561f06578672bcc455d5
diff --git a/dev-python/trimesh/trimesh-4.0.3.ebuild b/dev-python/trimesh/trimesh-4.0.3.ebuild
new file mode 100644
index 000000000000..a7073bf21ee0
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}