summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-12-03 18:45:44 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-12-03 18:45:44 -0500
commit3ee0085d375658e560b00f770de2d2a84af5ec42 (patch)
tree2ba86e7ad327fb60293e53c2a6089692dfbdc05a
parentnet-misc/stunnel: remove older versions (diff)
downloadgentoo-3ee0085d375658e560b00f770de2d2a84af5ec42.tar.gz
gentoo-3ee0085d375658e560b00f770de2d2a84af5ec42.tar.bz2
gentoo-3ee0085d375658e560b00f770de2d2a84af5ec42.zip
net-libs/libmicrohttpd: version bump to 0.9.46
Package-Manager: portage-2.2.20.1
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.46.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index 959c5c964379..a9037e70b901 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -1,2 +1,3 @@
DIST libmicrohttpd-0.9.42.tar.gz 1232516 SHA256 00352073367003da40607319e4090a6a8308748b59246ae80e9871f34dad7d5b SHA512 6516f545a5b81aa23bb0d22582f6d7e7f028069d94e0d33d9d6f929e111a3c0e0432eb43b26b4eec87860e8b9f50de38f1b5e6e20cd8faf30512e4891f29b9f3 WHIRLPOOL 9d42c08ee37042debf2e16ddd244c91375e4cecb9843e08d58581a9838677148d90d469bcd4890d4a0680a62e691c659394067da1c7060f7c4e49b309be4417c
DIST libmicrohttpd-0.9.45.tar.gz 1246332 SHA256 1075def48da9327be22441f4a3460d24159fae2bf4bcfb4ab6e7ca5e95e54a69 SHA512 670d1d1f47ea8657d389302c9bfa8b6d8d12658fb28ce6ed7549db0d4483b1023e7e7d419651f38cef5b024f853d83f336b365624a346b811c2d94ab0d84fb01 WHIRLPOOL 691c1577fd17f6db4bd1990dcfbe4f20cb8944dd51014b349d26bfc8844e367c337eb03c91342b2d9e9923979e36e7464530ed6808636085a2daa006c5295bf6
+DIST libmicrohttpd-0.9.46.tar.gz 1249529 SHA256 06dbd2654f390fa1e8196fe063fc1449a6c2ed65a38199a49bf29ad8a93b8979 SHA512 d45cd6e8ca1fb0e4d42110fa6ae5b49823d1b2ce66dd82d8b68757b79bf441e4103301af9437886b2c5d3296102ed8da17933a573da9649e7359305f8e678e46 WHIRLPOOL 09413fd2f39d1da727dc8756b7487dcfd7d7d143af27ac3add70c302b6a8fe5454c328a8a341a5bd69a6a0d52c4153c1dbaad3157f731bf35e4e67a0a2b512a3
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.46.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.46.ebuild
new file mode 100644
index 000000000000..a988b4abd4f3
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.46.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="epoll messages ssl static-libs test"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --disable-spdy \
+ --enable-postprocessor \
+ --runstatedir=/run \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}