summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-16 15:57:38 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-16 16:11:54 +0200
commit3ee1770ad00177804b7c4a712606ae7dcd0abfba (patch)
tree7615525dcac7850136a83ad9380a9fa117d35daa
parentdev-util/staruml-bin: fix LICENSE (diff)
downloadgentoo-3ee1770a.tar.gz
gentoo-3ee1770a.tar.bz2
gentoo-3ee1770a.zip
sci-libs/armadillo: Re-enable superlu support
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sci-libs/armadillo/armadillo-7.800.2.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sci-libs/armadillo/armadillo-7.800.2.ebuild b/sci-libs/armadillo/armadillo-7.800.2.ebuild
index 94954c6a1d6f..ad912b34eea8 100644
--- a/sci-libs/armadillo/armadillo-7.800.2.ebuild
+++ b/sci-libs/armadillo/armadillo-7.800.2.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/arma/${P}.tar.xz"
LICENSE="Apache-2.0"
SLOT="0/7"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="arpack blas debug doc examples hdf5 lapack mkl tbb test"
+IUSE="arpack blas debug doc examples hdf5 lapack mkl superlu tbb test"
REQUIRED_USE="test? ( lapack )"
RDEPEND="
@@ -22,9 +22,8 @@ RDEPEND="
arpack? ( sci-libs/arpack )
blas? ( virtual/blas )
lapack? ( virtual/lapack )
+ superlu? ( >=sci-libs/superlu-5 )
"
-# superlu? ( sci-libs/superlu )
-# needs superlu-5
DEPEND="${RDEPEND}
arpack? ( virtual/pkgconfig )
@@ -104,16 +103,16 @@ src_configure() {
-DLAPACK_FOUND=OFF
)
fi
-# if use superlu; then
-# mycmakeargs+=(
-# -DSuperLU_FOUND=ON
-# -DSuperLU_LIBRARIES="$($(tc-getPKG_CONFIG) --libs superlu)"
-# )
-# else
-# mycmakeargs+=(
-# -DSuperLU_FOUND=OFF
-# )
-# fi
+ if use superlu; then
+ mycmakeargs+=(
+ -DSuperLU_FOUND=ON
+ -DSuperLU_LIBRARIES="$($(tc-getPKG_CONFIG) --libs superlu)"
+ )
+ else
+ mycmakeargs+=(
+ -DSuperLU_FOUND=OFF
+ )
+ fi
cmake-utils_src_configure
}