summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-08 08:42:33 -0500
committerMichael Orlitzky <mjo@gentoo.org>2023-12-08 08:46:42 -0500
commit3f3dcbee1d366757fc869fa365717a7d31bae7c1 (patch)
treeb8bdd0d8fbd93c41aa8a740f2dc3b288c2a3d41e
parentapp-emacs/projectile: Add optfeature message (diff)
downloadgentoo-3f3dcbee1d366757fc869fa365717a7d31bae7c1.tar.gz
gentoo-3f3dcbee1d366757fc869fa365717a7d31bae7c1.tar.bz2
gentoo-3f3dcbee1d366757fc869fa365717a7d31bae7c1.zip
dev-lang/php: always use the system libcrypt
Unbundling things has inherent value, but this in particular should lead to better security. Thanks to hanno for noticing that it wasn't default! The removal of --enable-ipv6 is unrelated and should be a no-op since we append $(use_enable ipv6) to our econf args later on. Closes: https://bugs.gentoo.org/919439 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-lang/php/php-8.2.13-r1.ebuild (renamed from dev-lang/php/php-8.2.13.ebuild)2
-rw-r--r--dev-lang/php/php-8.3.0-r1.ebuild (renamed from dev-lang/php/php-8.3.0.ebuild)2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/php/php-8.2.13.ebuild b/dev-lang/php/php-8.2.13-r1.ebuild
index 7d6a005d1c10..a0aadbfbb272 100644
--- a/dev-lang/php/php-8.2.13.ebuild
+++ b/dev-lang/php/php-8.2.13-r1.ebuild
@@ -335,7 +335,7 @@ src_configure() {
--localstatedir="${EPREFIX}/var"
--without-pear
--without-valgrind
- --enable-ipv6
+ --with-external-libcrypt
$(use_enable threads zts)
)
diff --git a/dev-lang/php/php-8.3.0.ebuild b/dev-lang/php/php-8.3.0-r1.ebuild
index 195326a5aff5..c694a628967e 100644
--- a/dev-lang/php/php-8.3.0.ebuild
+++ b/dev-lang/php/php-8.3.0-r1.ebuild
@@ -289,7 +289,7 @@ src_configure() {
--localstatedir="${EPREFIX}/var"
--without-pear
--without-valgrind
- --enable-ipv6
+ --with-external-libcrypt
$(use_enable threads zts)
)