summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-11-09 12:38:23 -0600
committerJohn Helmert III <ajak@gentoo.org>2022-11-09 12:46:46 -0600
commit3f3ec2b1ef6b6295b847a134f4a098bf109239fc (patch)
tree89efbb17fa6d7be5e0f159fd50fa2eee55492e6a
parentdev-java/mockito: Stabilize 1.9.5-r3 ppc64, #880607 (diff)
downloadgentoo-3f3ec2b1.tar.gz
gentoo-3f3ec2b1.tar.bz2
gentoo-3f3ec2b1.zip
www-servers/varnish: add 7.1.2
Also reenable tests, disable the 4 tests that seem to be Gentoo-specific failures. Bug: https://bugs.gentoo.org/880627 Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--www-servers/varnish/Manifest1
-rw-r--r--www-servers/varnish/files/varnish-7.1.2-disable-tests.patch27
-rw-r--r--www-servers/varnish/varnish-7.1.2.ebuild102
3 files changed, 130 insertions, 0 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index c3b5fca20313..6778daa46ec0 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -1 +1,2 @@
DIST varnish-7.1.1.tgz 3742869 BLAKE2B d41e7214c3b51ac18b1a89012b48d3db58f4f777df675fa93d6ac75d3cf14b78af23f9d6e8b8686fdfa82add70a1a42e5e54f382506444ec81ad6d121a99e447 SHA512 7c3c081bd37c63b429337a25ebc0c14d780b0c4fd235d18b9ac1004e0bb2f65e70664c5bd25c5d941deeb6bc078f344fa2629cf0d641a0149fe29dcfa07ffcd2
+DIST varnish-7.1.2.tgz 3758689 BLAKE2B a5c05d9dd7c5f0cd4dc0cae8cc365b658a15d017c7fb19cbe17088f009304375eb123f35935045c35c61ec3dfd7d8858774c2bbc918cc436415bd50b8894bb3b SHA512 e16a4b75ede25f3812dfc4e95545e39a80022835b9155a4e42118f911e41b691cbedd296db48d307ba4a4d0d01df1149306d752de07cabe459ccbf5bcdd49238
diff --git a/www-servers/varnish/files/varnish-7.1.2-disable-tests.patch b/www-servers/varnish/files/varnish-7.1.2-disable-tests.patch
new file mode 100644
index 000000000000..81f0a989353b
--- /dev/null
+++ b/www-servers/varnish/files/varnish-7.1.2-disable-tests.patch
@@ -0,0 +1,27 @@
+commit 24bedea4085a41130b13934acb4946d456976dfb (HEAD -> master)
+Author: John Helmert III <ajak@gentoo.org>
+Date: Wed Nov 9 12:33:17 2022 -0600
+
+ disable tests which time out
+
+ These tests time out, but can't reproduce when running manually
+ (outside of sandbox).
+
+ Signed-off-by: John Helmert III <ajak@gentoo.org>
+
+diff --git a/bin/varnishtest/tests/r02686.vtc b/bin/varnishtest/tests.disabled/r02686.vtc
+similarity index 100%
+rename from bin/varnishtest/tests/r02686.vtc
+rename to bin/varnishtest/tests.disabled/r02686.vtc
+diff --git a/bin/varnishtest/tests/r02990.vtc b/bin/varnishtest/tests.disabled/r02990.vtc
+similarity index 100%
+rename from bin/varnishtest/tests/r02990.vtc
+rename to bin/varnishtest/tests.disabled/r02990.vtc
+diff --git a/bin/varnishtest/tests/u00008.vtc b/bin/varnishtest/tests.disabled/u00008.vtc
+similarity index 100%
+rename from bin/varnishtest/tests/u00008.vtc
+rename to bin/varnishtest/tests.disabled/u00008.vtc
+diff --git a/bin/varnishtest/tests/u00009.vtc b/bin/varnishtest/tests.disabled/u00009.vtc
+similarity index 100%
+rename from bin/varnishtest/tests/u00009.vtc
+rename to bin/varnishtest/tests.disabled/u00009.vtc
diff --git a/www-servers/varnish/varnish-7.1.2.ebuild b/www-servers/varnish/varnish-7.1.2.ebuild
new file mode 100644
index 000000000000..6fe4beac2068
--- /dev/null
+++ b/www-servers/varnish/varnish-7.1.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libedit
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ acct-user/varnish
+ acct-group/varnish
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ dev-python/sphinx
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-7.1.2-disable-tests.patch" )
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable jit pcre2-jit)
+ $(use_with jemalloc)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins vmod/vmod_*.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+
+ find "${ED}" -name "*.la" -delete || die
+}