summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2022-10-23 15:54:58 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2022-10-24 19:16:09 +0200
commit3f53b7ffae46da17b1e264959f474b97f888d21b (patch)
treeecc60e3fa141f899c94533131828280456d29cb8
parentsys-firmware/raspberrypi-wifi-ucode: drop 20210315.3_p5 (diff)
downloadgentoo-3f53b7ffae46da17b1e264959f474b97f888d21b.tar.gz
gentoo-3f53b7ffae46da17b1e264959f474b97f888d21b.tar.bz2
gentoo-3f53b7ffae46da17b1e264959f474b97f888d21b.zip
sys-boot/raspberrypi-firmware: add 1.20220830
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--sys-boot/raspberrypi-firmware/Manifest1
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20220830.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-boot/raspberrypi-firmware/Manifest b/sys-boot/raspberrypi-firmware/Manifest
index db0dff32615b..0fad6144ee39 100644
--- a/sys-boot/raspberrypi-firmware/Manifest
+++ b/sys-boot/raspberrypi-firmware/Manifest
@@ -1,2 +1,3 @@
DIST raspberrypi-firmware-1.20211118.tar.gz 193544570 BLAKE2B db6c7c2e247f668b02210fb181305c3244f3d8a30f923656bf15cf418cb26822844df5b39af62b483e9e49405e13a60e57d6826aa0f3c3698920e8fc568656e2 SHA512 54881fc31ca0c9de8d8ca41ad6418e9d149975fbadbc0409f4136d4a31e70d743d55a16d4c0942305077d463c952edaa48be56d22d015983ab672dcaf5f134e2
DIST raspberrypi-firmware-1.20220328.tar.gz 195699471 BLAKE2B e39ae746b46eb4f63aa2043df9fb60ce23b966d172e2c2c311942425e62896fb8ef171689c420bf2545065514a331e46c3bfb4d028eab8eea251357ee4c947f3 SHA512 b9e8676a94dce4621af25b8ba563a2dbd93f6fad61f5c5fb8b57b0ff5262151ff61598ce56a5f952f99f6e37f7c9ebf801a51849ee45ee328a168ca88e2522f3
+DIST raspberrypi-firmware-1.20220830.tar.gz 184738723 BLAKE2B 3675488a4ad9e3e8570eecfb56af2fd77d35dcc0da1cb14892a18e2b8471011411f0ec063c76fe51a72170df4d2f78acec11c0473272d6ba5248785c339fa3bd SHA512 9f5682254bf2596556b8759dd7b6ab1292ba6a28bf582f100682a1f14a03b43ac6ece654392e7a17f27db3940e8073b9e8645bd66aba8504a820fc29a3a1c500
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20220830.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20220830.ebuild
new file mode 100644
index 000000000000..595de0624e7e
--- /dev/null
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20220830.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mount-boot readme.gentoo-r1
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+ EGIT_CLONE_TYPE="shallow"
+else
+ SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="-* ~arm ~arm64"
+ S="${WORKDIR}/firmware-${PV}"
+fi
+
+DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+RESTRICT="binchecks strip"
+
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
+
+src_prepare() {
+ default
+
+ cp "${FILESDIR}"/${PN}-1.20201022-config.txt "${WORKDIR}" || die
+
+ if use arm64; then
+ # Force selection of the 64-bit kernel8.img to match our userland
+ echo "arm_64bit=1" >> "${WORKDIR}"/${PN}-1.20201022-config.txt || die
+ fi
+}
+
+src_install() {
+ insinto /boot
+ cd boot || die
+ doins bootcode.bin fixup*.dat start*elf
+ newins "${WORKDIR}"/${PN}-1.20201022-config.txt config.txt
+ newins "${FILESDIR}"/${PN}-1.20201022-cmdline.txt cmdline.txt
+ newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ local msg=""
+
+ if [[ -e "${ED}"/boot/cmdline.txt ]] && [[ -e /boot/cmdline.txt ]] ; then
+ msg+="/boot/cmdline.txt "
+ fi
+
+ if [[ -e "${ED}"/boot/config.txt ]] && [[ -e /boot/config.txt ]] ; then
+ msg+="/boot/config.txt "
+ fi
+
+ if [[ -n "${msg}" ]] ; then
+ msg="This package installs following files: ${msg}."
+ msg="${msg} Please remove (backup) your copies during install"
+ msg="${msg} and merge settings afterwards."
+ msg="${msg} Further updates will be CONFIG_PROTECTed."
+ die "${msg}"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}