summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-04-26 19:39:23 +0200
committerJeroen Roovers <jer@gentoo.org>2018-04-26 19:49:07 +0200
commit3f5868693234cd430cdd8b68d53513061989d3d8 (patch)
treebbfe64c82f75360db4d3f266d9cf4c12f50d42aa
parentdev-libs/vala-common: x86 stable (bug #652976) (diff)
downloadgentoo-3f5868693234cd430cdd8b68d53513061989d3d8.tar.gz
gentoo-3f5868693234cd430cdd8b68d53513061989d3d8.tar.bz2
gentoo-3f5868693234cd430cdd8b68d53513061989d3d8.zip
net-misc/youtube-dl: Version 2018.04.25.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2018.04.25.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 7fa6dc309a63..0354200c2831 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e31ac10063975ab636badf27e59b44743c72cddf05e3a431c49ffd0f7b40f9b005f4d90feff85d4ca889dee80833300b076 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96
DIST youtube-dl-2018.04.09.tar.gz 2944297 BLAKE2B 3c89b4d7de10f7ce181281788d0eb32d75fe1ee398b28ca1fb3a7dc0178c9f60a5a366b0db14d82e107fd00143d161165385f8797f8a34873c69cd3eb3ddeb94 SHA512 48c2d56493d5a0db911ea3e443dc7a87fe345de2da2094cad037901267480c3b44f8f927480547ffa527240ea4c1b650f31e01068ba72c49518c4895e554572f
DIST youtube-dl-2018.04.16.tar.gz 2947245 BLAKE2B 37e75ec41daa72e4259b6b7f809606ff1bb3ed352bf07733086273e1abe9c2b39a8b0238447100a507a8be421f5b568716959a7df9d30fbe954413ba7a7690e3 SHA512 fdf3115d0deadca60a0316264289e79b5f7bb17af395264203a5ccef1b9cd8d05aa2348042ee08bf2f5f1475951e076662331a561aa101b904873446ed118cdc
+DIST youtube-dl-2018.04.25.tar.gz 2947762 BLAKE2B 6c6ee1e67eab82418bcc2f5f4556b02eba77ddf830603096e29dd793bf052403379838bf2d920d7ebc39be9ec4e7aba33799435f2980c991873d636d10be5e9a SHA512 89eda20c45575bbf894138b2fd41e38abf3cc21504fe141754544c436bf6030fa94a1496abf6b8c4bfdc77bdf1c8c1d320bf0f1a0ecc2d007409ef9421922c15
diff --git a/net-misc/youtube-dl/youtube-dl-2018.04.25.ebuild b/net-misc/youtube-dl/youtube-dl-2018.04.25.ebuild
new file mode 100644
index 000000000000..37bffad45c8e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2018.04.25.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
+ pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
+ slutload spankbang spankwire sunporno thisav vporn watchindianporn
+ xbef xnxx xtube xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+}