summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-22 08:57:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-22 09:25:25 +0200
commit3f5df533b3935548872fdd38432dd6ea8677eda6 (patch)
tree05c7f0df8cca453eb287b59723c3c885af4f203b
parentdev-python/astroid: Bump to 2.6.5 (diff)
downloadgentoo-3f5df533.tar.gz
gentoo-3f5df533.tar.bz2
gentoo-3f5df533.zip
dev-python/pylint: Bump to 2.9.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.9.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index ee45bc7fc211..3d1653ded47d 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -3,3 +3,4 @@ DIST pylint-2.9.0.gh.tar.gz 768301 BLAKE2B a86ccb83d3155acee0165dc7b0095f5b7741c
DIST pylint-2.9.1.gh.tar.gz 769124 BLAKE2B feabb520c22722df73471e87e05f22f0fb937113c9d02e39bf4e2554479c58a5044afe565c107e9478d868284b8875fec65b976633dddb4bc9d7748b35640218 SHA512 7aea388c6e62fd53e6775a4732da87269f3df22f995241621eb9b8d72c8573b6a4fa9545b1553db91f09eee013bd695e075d69c35436b05623576f13f1317cb6
DIST pylint-2.9.3.gh.tar.gz 770364 BLAKE2B 3892286ffbd79b417c6decba44bce97f45192299ac8e2ec0e24770b2dd6cf1c28bac790626a478d47a6124ec0470ea9fc0d4230c5a1e807532852844445bb95a SHA512 45c037b970b66254b54a4810a5609dc098b5493d409826333e6a75f9ff0fc02921162711d88c45fd2f437e6521f639c33b25b714830a977c501612ee497501bb
DIST pylint-2.9.4.gh.tar.gz 777252 BLAKE2B 84bc535b3c471be5d01a02ee67494d993cc257f0938e1bb0e35b1d64415d256c4f0dabd45cdc3319716c67e5e71ea935b63633f56b97013bd8616296343709d5 SHA512 9b5db20cf2d858e662c309b11cf28bf247b7c5f90de4f747733a0288ff4acced02e0e6b83145e7d940772eb9debf297b9ee6976e0f3ffbd73aaacaa3f4cb51e6
+DIST pylint-2.9.5.gh.tar.gz 778090 BLAKE2B cbcf5427665f56cc37afd08fb537fcc3f17697ca7cdbd7da97bad4093f344c9b961a156f5d141e070fa84c7e07293175a70585a8c996c9cffb7cef80717752af SHA512 84695bae88704391752f4b0944e39f5b44933fee8d88a8839729845b93bbe59876da08ab98645217c4ff2a98fd793a92063123b25a595fb332ce0a3943bcf7e7
diff --git a/dev-python/pylint/pylint-2.9.5.ebuild b/dev-python/pylint/pylint-2.9.5.ebuild
new file mode 100644
index 000000000000..75d26e73965e
--- /dev/null
+++ b/dev-python/pylint/pylint-2.9.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint/"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/astroid-2.7[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.6.5[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests ${skipped_tests[@]/#/--deselect }
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}