summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-27 19:37:29 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-27 19:47:14 +0200
commit3f9528b9570efab4f66c7094305dc21a5b6e846a (patch)
tree9cff2b7a006e6202db6cd29dfb8e99bac25d88bd
parentdev-python/deepdiff: Enable py3.12 (diff)
downloadgentoo-3f9528b9570efab4f66c7094305dc21a5b6e846a.tar.gz
gentoo-3f9528b9570efab4f66c7094305dc21a5b6e846a.tar.bz2
gentoo-3f9528b9570efab4f66c7094305dc21a5b6e846a.zip
dev-python/indexed-gzip: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/indexed-gzip/Manifest2
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild55
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.8.3.ebuild56
3 files changed, 0 insertions, 113 deletions
diff --git a/dev-python/indexed-gzip/Manifest b/dev-python/indexed-gzip/Manifest
index 8cd174bfec91..bf3218699d0b 100644
--- a/dev-python/indexed-gzip/Manifest
+++ b/dev-python/indexed-gzip/Manifest
@@ -1,3 +1 @@
-DIST indexed_gzip-1.7.1.tar.gz 74457 BLAKE2B b22d2120adac59e64f5bcf38c831bb54ce5d6c3dd1e959eece9a454908d9ce2aa5dc10557bd63823616bedfe9d0c039a3f1c0512ef1d22a54437353c57e15158 SHA512 fa27e476f115eca1d1d3892c3480de97cb407bd489737bebc44eb28e92be91e14312cde33a67af145b44c7d93ccc706498c2cbfe6cbff5b9b091dd083cde0f7e
-DIST indexed_gzip-1.8.3.tar.gz 74621 BLAKE2B e8092eea93235b7e6a154b34d12194ffbd3ecb88f2891b8b60ab526fa6a9247c78afded19b284b8143981a83333f376e82b65003ada61ce2efe7378fe84749a4 SHA512 f33fb19938ae39e4ede71f3f2a328f56e7fad5ee4872b25c0977ded1819541e9e63d64a1379b022cd82af79a5c0967d8fdde589d2276841a4b0e9d3179229035
DIST indexed_gzip-1.8.5.tar.gz 74696 BLAKE2B 5db7a9c372950e60f4e6f5905a6bf5b01c76007174a77393176d969e87197beefc81d72e5280ac057fcfd3c752e5f8b2923326e3ed2e825fd34315dd23a179b0 SHA512 617b7406ff2e579c41ceafcfb64bd9ba33599f9f810afb5b3abad49825ae274265b8f8eeaf54285d8df11dd9c498a13752455263a51817be11301ed73aeb0230
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild
deleted file mode 100644
index 44aac738ce10..000000000000
--- a/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Fast random access of gzip files in Python"
-HOMEPAGE="
- https://pypi.org/project/indexed-gzip/
- https://github.com/pauldmccarthy/indexed_gzip/
-"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- sys-libs/zlib:=
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # strip custom "clean" command that doesn't support "-a"
- # https://bugs.gentoo.org/838955
- # TODO: this can be removed once distutils-r1 stops using clean
- sed -e '/cmdclass/d' -i setup.py || die
- distutils-r1_src_prepare
-}
-
-src_compile() {
- if use test; then
- export INDEXED_GZIP_TESTING=1
- fi
- distutils-r1_src_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
- epytest
-}
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.8.3.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.8.3.ebuild
deleted file mode 100644
index 9e9fb985434c..000000000000
--- a/dev-python/indexed-gzip/indexed-gzip-1.8.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="Fast random access of gzip files in Python"
-HOMEPAGE="
- https://pypi.org/project/indexed-gzip/
- https://github.com/pauldmccarthy/indexed_gzip/
-"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- sys-libs/zlib:=
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # strip custom "clean" command that doesn't support "-a"
- # https://bugs.gentoo.org/838955
- # TODO: this can be removed once distutils-r1 stops using clean
- sed -e '/cmdclass/d' -i setup.py || die
- distutils-r1_src_prepare
-}
-
-src_compile() {
- if use test; then
- export INDEXED_GZIP_TESTING=1
- fi
- distutils-r1_src_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
- epytest -n "$(makeopts_jobs)" --dist=worksteal
-}