summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-16 09:27:42 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-16 09:28:06 +0200
commit3fa54e38369d6e614fca87a30bfb3a469a7008e8 (patch)
treef7b35e8619c11154eafa267e928a9c42591f3954
parentx11-proto/xcb-proto: use HTTPS for freedesktop.org (diff)
downloadgentoo-3fa54e38369d6e614fca87a30bfb3a469a7008e8.tar.gz
gentoo-3fa54e38369d6e614fca87a30bfb3a469a7008e8.tar.bz2
gentoo-3fa54e38369d6e614fca87a30bfb3a469a7008e8.zip
dev-python/dbusmock: version bump 0.16.7 → 0.16.9
Package-Manager: Portage-2.3.7, Repoman-2.3.3
-rw-r--r--dev-python/dbusmock/Manifest1
-rw-r--r--dev-python/dbusmock/dbusmock-0.16.9.ebuild46
-rw-r--r--dev-python/dbusmock/files/0.16.9-disable-style-tests.patch14
-rw-r--r--dev-python/dbusmock/files/0.16.9-replace-dbus-launch.patch76
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-python/dbusmock/Manifest b/dev-python/dbusmock/Manifest
index 456da5e87fea..d4ff31f5ca6b 100644
--- a/dev-python/dbusmock/Manifest
+++ b/dev-python/dbusmock/Manifest
@@ -1 +1,2 @@
DIST dbusmock-0.16.7.tar.gz 70544 SHA256 2d2ea892fa4633c3ec6ac1e912120ec493047a5c6522849b7d1c95ad755bce75 SHA512 749728b966b1e067a0a8bd61ee64c1c7ff22751ccb48e15096d041e78c6e779d787160ee191e90daa3177b92c0ee45c66af74b2dd4e4bcb570892b431ec13467 WHIRLPOOL 921c47fb0b86a6a3368c3b37c27f30b75edacefb46f1a726e39f35eb7b1ea7d0f78c3a7e04b218016c558578625ff28188bfece7cbc7aa06405effe4ab614f92
+DIST dbusmock-0.16.9.tar.gz 71014 SHA256 892b770a7f6c800fd6c0a9d102ef085a9371cc4eaed95dabbd740913dc08dd9b SHA512 3aa91f6ede054ed3d3a69f68f3886094e881d266a8f09c7d08a34d10b080a77facde8aae01e75232472c2e643574fe897dae2c3588f5ad9ecf4ec4e67f404f54 WHIRLPOOL 192d522a79b365630d0ef2069b5cf1cdae3ddb7896ad9db590ff8e7a180d44ac101ed123c035c272c27cc96cb33bbed1a9e00bf08ab0e248554f3ed374ead1ee
diff --git a/dev-python/dbusmock/dbusmock-0.16.9.ebuild b/dev-python/dbusmock/dbusmock-0.16.9.ebuild
new file mode 100644
index 000000000000..f232c0a9d8c0
--- /dev/null
+++ b/dev-python/dbusmock/dbusmock-0.16.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc"
+IUSE="test"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/0.16.9-disable-style-tests.patch
+ "${FILESDIR}"/0.16.9-replace-dbus-launch.patch
+)
+
+python_test() {
+ nosetests --verbose || die "tests fail under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( NEWS README.rst )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dbusmock/files/0.16.9-disable-style-tests.patch b/dev-python/dbusmock/files/0.16.9-disable-style-tests.patch
new file mode 100644
index 000000000000..cb7febdb4e53
--- /dev/null
+++ b/dev-python/dbusmock/files/0.16.9-disable-style-tests.patch
@@ -0,0 +1,14 @@
+These tests are bound to fail dependending on QA tools updates
+
+https://github.com/martinpitt/python-dbusmock/issues/28
+
+--- a/tests/test_code.py 2017-08-16 09:20:43.848503995 +0200
++++ b/tests/test_code.py 2017-08-16 09:20:54.410177037 +0200
+@@ -21,6 +21,7 @@
+ pycodestyle = None
+
+
++@unittest.skip('style tests')
+ class StaticCodeTests(unittest.TestCase):
+ @unittest.skipIf(subprocess.call(['which', 'pyflakes'], stdout=subprocess.PIPE) != 0,
+ 'pyflakes not installed')
diff --git a/dev-python/dbusmock/files/0.16.9-replace-dbus-launch.patch b/dev-python/dbusmock/files/0.16.9-replace-dbus-launch.patch
new file mode 100644
index 000000000000..54149ed033aa
--- /dev/null
+++ b/dev-python/dbusmock/files/0.16.9-replace-dbus-launch.patch
@@ -0,0 +1,76 @@
+From 9470c54a2836795974e83e55ea859e4653b20b37 Mon Sep 17 00:00:00 2001
+From: Martin Pitt <martin@piware.de>
+Date: Mon, 19 Jun 2017 16:31:28 +0200
+Subject: [PATCH] Call dbus-daemon directly instead of dbus-launch
+
+dbus-launch is X11 specific and being deprecated.
+
+Adjust documentation to use dbus-run-session instead.
+
+https://bugs.debian.org/836053
+---
+ NEWS | 4 ++++
+ README.rst | 6 +++---
+ dbusmock/testcase.py | 18 ++++++++++--------
+ 3 files changed, 17 insertions(+), 11 deletions(-)
+
+diff --git a/NEWS b/NEWS
+index c1250ea..181a4df 100644
+--- a/NEWS
++++ b/NEWS
+@@ -1,3 +1,7 @@
++0.17 (UNRELEASED)
++-----------------
++ - Call dbus-daemon directly instead of dbus-launch. (Debian #836053)
++
+ 0.16.9 (2017-06-19)
+ -------------------
+ - NetworkManager template: Fix type of 'State' property in AddActiveConnection()
+diff --git a/README.rst b/README.rst
+index 3dc4552..310e1ac 100644
+--- a/README.rst
++++ b/README.rst
+@@ -118,9 +118,9 @@ Let's walk through:
+ Simple example from shell
+ -------------------------
+
+-We use the actual session bus for this example. You can use ``dbus-launch`` to
+-start a private one as well if you want, but that is not part of the actual
+-mocking.
++We use the actual session bus for this example. You can use
++``dbus-run-session`` to start a private one as well if you want, but that is
++not part of the actual mocking.
+
+ So let's start a mock at the D-Bus name ``com.example.Foo`` with an initial
+ "main" object on path /, with the main D-Bus interface
+diff --git a/dbusmock/testcase.py b/dbusmock/testcase.py
+index 825c61f..49787e2 100644
+--- a/dbusmock/testcase.py
++++ b/dbusmock/testcase.py
+@@ -97,16 +97,18 @@ def start_dbus(klass, conf=None):
+ Normally you do not need to call this directly. Use start_system_bus()
+ and start_session_bus() instead.
+ '''
+- argv = ['dbus-launch']
++ argv = ['dbus-daemon', '--fork', '--print-address=1', '--print-pid=1']
+ if conf:
+ argv.append('--config-file=' + conf)
+- out = subprocess.check_output(argv, universal_newlines=True)
+- variables = {}
+- for line in out.splitlines():
+- (k, v) = line.split('=', 1)
+- variables[k] = v
+- return (int(variables['DBUS_SESSION_BUS_PID']),
+- variables['DBUS_SESSION_BUS_ADDRESS'])
++ else:
++ argv.append('--session')
++ lines = subprocess.check_output(argv, universal_newlines=True).strip().splitlines()
++ assert len(lines) == 2, 'expected exactly 2 lines of output from dbus-daemon'
++ # usually the first line is the address, but be lenient and accept any order
++ try:
++ return (int(lines[1]), lines[0])
++ except ValueError:
++ return (int(lines[0]), lines[1])
+
+ @classmethod
+ def stop_dbus(klass, pid):