summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-17 13:57:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-17 17:11:03 +0200
commit3fa6ae334ec0fe9a243d8e2aa88c0e265219b001 (patch)
treea8f77184f05a31d867fbae0e3a0d3cf04a6843d1
parentdev-python/pydevd: Add missing dep on dev-python/pytest-xdist (diff)
downloadgentoo-3fa6ae33.tar.gz
gentoo-3fa6ae33.tar.bz2
gentoo-3fa6ae33.zip
dev-python/loky: Run tests in parallel
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/loky/loky-3.4.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/loky/loky-3.4.1.ebuild b/dev-python/loky/loky-3.4.1.ebuild
index 8503470eaf5a..456f7062da8e 100644
--- a/dev-python/loky/loky-3.4.1.ebuild
+++ b/dev-python/loky/loky-3.4.1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="Robust and reusable Executor for joblib"
HOMEPAGE="
@@ -30,6 +30,7 @@ BDEPEND="
test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
@@ -44,6 +45,8 @@ python_test() {
tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
)
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# high memory test needs a lot of memory + is broken on 32-bit platforms
- epytest --skip-high-memory
+ epytest --skip-high-memory \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
}