summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-27 10:10:46 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-27 10:41:03 +0200
commit3faac4e1aeba6299797ff0fc956d8d4bd1f9db70 (patch)
tree7d177a15eb26f02283b6be4fd08734ed30d21b17
parentapp-shells/posh: Drop old (diff)
downloadgentoo-3faac4e1aeba6299797ff0fc956d8d4bd1f9db70.tar.gz
gentoo-3faac4e1aeba6299797ff0fc956d8d4bd1f9db70.tar.bz2
gentoo-3faac4e1aeba6299797ff0fc956d8d4bd1f9db70.zip
dev-lang/python-exec: Drop old
-rw-r--r--dev-lang/python-exec/Manifest1
-rw-r--r--dev-lang/python-exec/python-exec-2.4.4.ebuild133
2 files changed, 0 insertions, 134 deletions
diff --git a/dev-lang/python-exec/Manifest b/dev-lang/python-exec/Manifest
index e8877dd4a63c..e344e92d484a 100644
--- a/dev-lang/python-exec/Manifest
+++ b/dev-lang/python-exec/Manifest
@@ -1,2 +1 @@
-DIST python-exec-2.4.4.tar.bz2 86945 BLAKE2B 3ee2be57711c45e5821ba4cc54e76e4341056221a34277ced8ab5ebffc4d6af63fbe515f73bd84a1a7a82047a008b72fd2935e61b09b0b852624329b3be22e37 SHA512 26b76960430dc3b2b79aab5e8a72498144d4e78bed5291fe9361afe081f0e8d70049a74ec29384cb0fc199f76c23499324d2eddcaea521ef33d88e61b1b674f9
DIST python-exec-2.4.5.tar.bz2 87137 BLAKE2B 2434bee0bcc64a78a83254d6b6f733ef0748d8209ff70654fc57ac50563d4f32be64705a3c56eefef4e173a238b272d00bef4929982a729a097b82a3a2b0b5b1 SHA512 8c1a520c565afa775cad0e8b88248b688814664e588f683fc2b2c039ee0494b168ebd3cd1042b8b7fe2583f287cf55b22ea0585bfb43efe2f8450d809cde0b21
diff --git a/dev-lang/python-exec/python-exec-2.4.4.ebuild b/dev-lang/python-exec/python-exec-2.4.4.ebuild
deleted file mode 100644
index 96c08a46bfb0..000000000000
--- a/dev-lang/python-exec/python-exec-2.4.4.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Kids, don't do this at home!
-inherit python-utils-r1
-PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
-
-# Inherited purely to have PYTHON_TARGET flags which will satisfy USE
-# dependencies and trigger necessary rebuilds.
-inherit python-r1
-
-DESCRIPTION="Python script wrapper"
-HOMEPAGE="https://github.com/mgorny/python-exec/"
-SRC_URI="https://github.com/mgorny/${PN}/releases/download/${P}/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# eselect-python because of /usr/bin/python* collisions and new config
-# python versions because of missing $scriptdir/python* symlinks
-RDEPEND="
- !<app-eselect/eselect-python-20160206
- !<dev-lang/python-2.7.10-r4:2.7
- !<dev-lang/python-3.3.5-r4:3.3
- !<dev-lang/python-3.4.3-r4:3.4
- !<dev-lang/python-3.5.0-r3:3.5"
-
-src_configure() {
- local pyimpls=() i EPYTHON
- for i in "${PYTHON_COMPAT[@]}"; do
- python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
- done
-
- local myconf=(
- --with-python-impls="${pyimpls[*]}"
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- # Prepare and own the template
- sed -n -e '/^#/p' config/python-exec.conf.example \
- > "${T}"/python-exec.conf || die
- insinto /etc/python-exec
- doins "${T}"/python-exec.conf
-
- local f
- for f in python{,2,3}; do
- # symlink the C wrapper for python to avoid shebang recursion
- # bug #568974
- dosym python-exec2c /usr/bin/"${f}"
- done
- for f in python{,2,3}-config 2to3 idle pydoc pyvenv; do
- # those are python scripts (except for new python-configs)
- # so symlink them via the python wrapper
- dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
- done
-}
-
-pkg_preinst() {
- if [[ -e ${EROOT}etc/python-exec/python-exec.conf ]]; then
- # preserve current configuration
- cp "${EROOT}"etc/python-exec/python-exec.conf \
- "${ED}"etc/python-exec/python-exec.conf || die
- else
- # preserve previous Python version preference
- local py old_pythons=()
- local config_base=${EROOT}etc/env.d/python
-
- # start with the 'global' preference (2 vs 3)
- if [[ -f ${config_base}/config ]]; then
- old_pythons+=( "$(<${config_base}/config)" )
- fi
-
- # then try specific py3 selection
- for py in 3; do
- local target=
-
- if [[ -f ${config_base}/python${py} ]]; then
- # try the newer config files
- target=$(<${config_base}/python${py})
- elif [[ -L ${EROOT}/usr/bin/python${py} ]]; then
- # check the older symlink format
- target=$(readlink "${EROOT}/usr/bin/python${py}")
-
- # check if it's actually old eselect symlink
- [[ ${target} == python?.? ]] || target=
- fi
-
- # add the extra target if found and != global
- if [[ ${target} && ${old_pythons[0]} != ${target} ]]; then
- old_pythons+=( "${target}" )
- fi
- done
-
- if [[ ${old_pythons[@]} ]]; then
- elog "You seem to have just upgraded into the new version of python-exec"
- elog "that uses python-exec.conf for configuration. The ebuild has attempted"
- elog "to convert your previous configuration to the new format, resulting"
- elog "in the following preferences (most preferred version first):"
- elog
- for py in "${old_pythons[@]}"; do
- elog " ${py}"
- done
- elog
- elog "Those interpreters will be preferred when running Python scripts or"
- elog "calling wrapped Python executables (python, python2, pydoc...)."
- elog "If none of the preferred interpreters are supported, python-exec will"
- elog "fall back to the newest supported Python version."
- elog
- elog "Please note that due to the ambiguous character of the old settings,"
- elog "you may want to modify the preference list yourself. In order to do so,"
- elog "open the following file in your favorite editor:"
- elog
- elog " ${EROOT}etc/python-exec/python-exec.conf"
- elog
- elog "For more information on the new configuration format, please read"
- elog "the comment on top of the installed configuration file."
-
- local IFS=$'\n'
- echo "${old_pythons[*]}" \
- >> "${ED}"etc/python-exec/python-exec.conf || die
- fi
- fi
-}