summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-25 06:18:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-25 06:56:53 +0200
commit3fbfbfc647673d0f443564035c66a943a0cb4ac3 (patch)
treed08fddc393320084b70ffb7cb0494a49cdb19474
parentdev-python/httpretty: Bump to 1.1.3 (diff)
downloadgentoo-3fbfbfc647673d0f443564035c66a943a0cb4ac3.tar.gz
gentoo-3fbfbfc647673d0f443564035c66a943a0cb4ac3.tar.bz2
gentoo-3fbfbfc647673d0f443564035c66a943a0cb4ac3.zip
dev-python/pyproj: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/pyproj-3.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index 37f1b3150498..e39eabb0e2d5 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1 +1,2 @@
DIST pyproj-3.0.1.tar.gz 168962 BLAKE2B 3271d604148c122f4dfdd68c4237e1911f30da7cc858128d644b6b6807c3e49450e0b42c385d37bbe1cfa5ab80d635e7f620d41bf5089af6b49a542eb9b3fcd0 SHA512 f5ae0ede1deaa93757cb98cc680d6e47a19b9f5c0ce5e357c2ecfe96f764ff59ec7285c606162da38573123d21f12f1df82354f1d2205149970af2d7d63c2689
+DIST pyproj-3.1.0.tar.gz 182603 BLAKE2B d4e95f62b10b282e7bbfcb7a2059a11a489e53402cbb1760b7da73248dfc05de6be8ca820e55d34c9270eea38178f1fb934bd5ffc389833b3734b87b79991187 SHA512 21a5d08207676d8d9722cb5e3b13ed68f03b1a2aa034c20c61bb8dab5d204dd968ba9a3df1b0c43ed174e082725c7624efb75a0c9c3df920808cbcb44f4d170a
diff --git a/dev-python/pyproj/pyproj-3.1.0.ebuild b/dev-python/pyproj/pyproj-3.1.0.ebuild
new file mode 100644
index 000000000000..6061e44b117b
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="https://github.com/pyproj4/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_p/.post}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND=">=sci-libs/proj-7.2.0:="
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # TODO
+ test/test_datum.py
+ test/test_transformer.py::test_transform_wgs84_to_alaska
+ test/test_transformer.py::test_repr__conditional
+ test/test_transformer.py::test_transformer_group__unavailable
+ test/test_transformer.py::test_transformer_group__network_disabled
+ test/test_transformer.py::test_transformer_group__download_grids__directory
+ test/crs/test_crs.py::test_coordinate_operation_grids__alternative_grid_name
+ )
+
+ distutils_install_for_testing
+ cp -r test "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ epytest --import-mode=append -m "not network" \
+ ${deselect[@]/#/--deselect } test
+}