summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-03 13:32:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-03 14:29:31 +0100
commit3fd01bd87ec4e79653d66c4ec2ea617f83ae91db (patch)
tree9a1c99723689abf8a28ff59ceba6bc09128726d0
parentapp-shells/bash-completion: Remove unused inherits (diff)
downloadgentoo-3fd01bd8.tar.gz
gentoo-3fd01bd8.tar.bz2
gentoo-3fd01bd8.zip
app-shells/bash-completion: Reformat
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-shells/bash-completion/bash-completion-2.11.ebuild22
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild17
2 files changed, 28 insertions, 11 deletions
diff --git a/app-shells/bash-completion/bash-completion-2.11.ebuild b/app-shells/bash-completion/bash-completion-2.11.ebuild
index a1fa288f505d..6620da126225 100644
--- a/app-shells/bash-completion/bash-completion-2.11.ebuild
+++ b/app-shells/bash-completion/bash-completion-2.11.ebuild
@@ -5,13 +5,17 @@ EAPI=7
BASHCOMP_P=bashcomp-2.0.3
PYTHON_COMPAT=( python3_{9..11} )
+
inherit python-any-r1
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="https://github.com/scop/bash-completion"
SRC_URI="
https://github.com/scop/bash-completion/releases/download/${PV}/${P}.tar.xz
- eselect? ( https://github.com/mgorny/bashcomp2/releases/download/v${BASHCOMP_P#*-}/${BASHCOMP_P}.tar.gz )"
+ eselect? (
+ https://github.com/mgorny/bashcomp2/releases/download/v${BASHCOMP_P#*-}/${BASHCOMP_P}.tar.gz
+ )
+"
LICENSE="GPL-2+"
SLOT="0"
@@ -20,9 +24,11 @@ IUSE="+eselect test"
RESTRICT="!test? ( test )"
# completion collision with net-fs/mc
-RDEPEND=">=app-shells/bash-4.3_p30-r1:0
+RDEPEND="
+ >=app-shells/bash-4.3_p30-r1:0
sys-apps/miscfiles
- !!net-fs/mc"
+ !!net-fs/mc
+"
DEPEND="
test? (
${RDEPEND}
@@ -30,8 +36,11 @@ DEPEND="
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
')
- )"
-PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
+ )
+"
+PDEPEND="
+ >=app-shells/gentoo-bashcomp-20140911
+"
strip_completions() {
# Remove unwanted completions.
@@ -76,8 +85,9 @@ pkg_setup() {
}
src_prepare() {
- use eselect &&
+ if use eselect; then
eapply "${WORKDIR}/${BASHCOMP_P}/bash-completion-blacklist-support.patch"
+ fi
# redhat-specific, we strip these completions
rm test/t/test_if{down,up}.py || die
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index db9e158ca8ee..b6d3b0aa9615 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{9..11} )
+
inherit autotools git-r3 python-any-r1
DESCRIPTION="Programmable Completion for bash"
@@ -17,9 +18,11 @@ IUSE="+eselect test"
RESTRICT="!test? ( test )"
# completion collision with net-fs/mc
-RDEPEND=">=app-shells/bash-4.3_p30-r1:0
+RDEPEND="
+ >=app-shells/bash-4.3_p30-r1:0
sys-apps/miscfiles
- !!net-fs/mc"
+ !!net-fs/mc
+"
DEPEND="
test? (
${RDEPEND}
@@ -27,8 +30,11 @@ DEPEND="
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
')
- )"
-PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
+ )
+"
+PDEPEND="
+ >=app-shells/gentoo-bashcomp-20140911
+"
strip_completions() {
# Remove unwanted completions.
@@ -116,9 +122,10 @@ src_install() {
dodoc AUTHORS CHANGES CONTRIBUTING.md README.md
# install the eselect module
- use eselect &&
+ if use eselect; then
emake -C "${WORKDIR}"/bashcomp2 DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" install
+ fi
}
pkg_postinst() {